cancel
Showing results for 
Search instead for 
Did you mean: 

Machinery Library used from Teamcenter previews not displayed

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hi guys,

 

I've installed Machinery Library to the Corporate Server using Infodba.

Added the path to client's NX default to get the library from Teamcenter.

Everything's fine except I don't see the preview images on the client's NX.

I can add any of the parts to an assembly without problems.

What can we do?

 

Cem

8 REPLIES

Re: Machinery Library used from Teamcenter previews not displayed

Siemens Phenom Siemens Phenom
Siemens Phenom
Part Families do not generate preview images. That's one of their drawbacks.

With best regards,

Larry Carpenter, P.E.
CAxPLM Architect, Siemens Molecular Imaging
Vice Technical Director, PLM World, Inc (www.plmworld.org<>)

Siemens Medical Solutions USA, Inc.
2501 North Barrington Road
Hoffman Estates, IL 60192, USA
Tel.: +1 847 304-7372<>
mailto:larry.carpenter@siemens.com

This message and any attachments are solely for the use of intended recipients. The information contained herein may include trade secrets, protected health or personal information, privileged or otherwise confidential information. Unauthorized review, forwarding, printing, copying, distributing, or using such information is strictly prohibited and may be unlawful. If you are not an intended recipient, you are hereby notified that you received this email in error, and that any review, dissemination, distribution or copying of this email and any attachment is strictly prohibited. If you have received this email in error, please contact the sender and delete the message and any attachment from your system. Thank you for your cooperation

Larry Carpenter, P.E.
CAxPLM Architect @ Siemens Molecular Imaging
Past Board Member @ PLM World, Inc,

Re: Machinery Library used from Teamcenter previews not displayed

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hi Larry,

 

Thanks for the answer.

This situation is like this on my customer.

 

I have a corporate server installed on a VM on my computer and I also installed machinery library to that.

On my host, I connect to that database and I can see the previews in my rich client as you can see.

Any ideas?

123.jpg

Re: Machinery Library used from Teamcenter previews not displayed

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Cem,

 

Can you give us a few more details about your setup for VM and Host?

Where is NX installed?

Where is the Mach Lib installed?

 

Sometimes NX needs to be installed on the server in order to support TC-Graphics-Builder. With VM and Host installations, this can get a little confusing.

 

Best,

/Randy


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Machinery Library used from Teamcenter previews not displayed

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Hi Randy,

 

These are my VM

NX10 - C:\Apps\PLM\nx10

Teamcenter Rapid Start - C:\Apps\PLM\tc10rs

 

On my host

NX10 C:\Program Files\Siemens\NX 10.0

TC Rapid Start - D:\TcRS_clnt

 

With this setup the MAchinery Library gives previews.

 

On my customer there is a problem.

 

I don't remember installing Graphics Builder and just checked on my VM's corporate server in TEM there is no option about that.

 

Cem

Re: Machinery Library used from Teamcenter previews not displayed

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

So the VM has NX installed but the customer probably doesn't have it on the server. The tc_graphicsbuilder.exe is part of the NX installation (%UGII_BASE_DIR%\UGMANAGER).

 

Best,

/Randy


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Machinery Library used from Teamcenter previews not displayed

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Actually I also have NX installed on the server.

I used that to import NX templates to Teamcenter.

It is still installed.

Should I do something more?

 

Cem

Re: Machinery Library used from Teamcenter previews not displayed

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Then I'm guessing its a graphics card issue.

 

Best,

/Randy


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Machinery Library used from Teamcenter previews not displayed

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor
On the client or the server?

Should I do anything to try to re-create the previews?


Sayg?lar?mla,

Cem ALPAY, Y?netici
??GEN YAZILIM LTD. ?T?.
TEL: 0216 550 52 06

[IMZA_22]