cancel
Showing results for 
Search instead for 
Did you mean: 

Naming rule for object_name not working

Creator
Creator

Hi,

 i've spent a couple of days trying to get different variations of naming rule to work with object_name.

Why is it is on object_name? Well, when our leagcy data was uplifted into TC, item names contained characters that did not adhere to the Unicode system employed.

 

So we want to put in "barriers" to prevent any further use of these characters. However, even a simple pattern of

 

 "[A-Z0-9]+"

 

prevents a simple name that accurately adheres to this rule from working.

We've applied nmaing rules to numbered attributes before without any issue, but this has stumped me.

 

Is our approach wrong here? or is our application of the naming rule incorrect?

Thanks in advance.

5 REPLIES

Re: Naming rule for object_name not working

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello,

 

Can you share the item name that is not adhering to this pattern?

 

the pattern '[A-Z0-9]+' translates to: 

One or more Uppercase letters or numbers in any order

 

Starting TC10.x, naming rules are allowed on all attributes.

 

Harish

Re: Naming rule for object_name not working

Creator
Creator

thank you for your response.

 

this is the message that follows when attempting to adhere to the naming rule as it is now:

 

Capture.JPG

 

We're currently on 10.1.6

Re: Naming rule for object_name not working

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
The error is correct. You did not specify that a space was allowed in the rule and you used lowercase "abc" where the rule only allows uppercase.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Naming rule for object_name not working

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

as @RandyEllsworth mentioned, you would have to include white spaces in your regex (like this "") if you plan to allow white spaces in item name.

 

Harish

Re: Naming rule for object_name not working

Creator
Creator

I had tried that in an earlier iteration, however, that did not work.

 

I can say now that the regex works. Thank you for your assitance Randy and Harish.