cancel
Showing results for 
Search instead for 
Did you mean: 

Need advice on troubleshooting client crash

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hello,

 

I am quite new to Teamcenter and am experimenting with installing and administering environments within virtual machines, so bear with me!

 

My problem is java keeps crashing on me for some reason, and it became gradually worse. The steps which I have taken are summarized below in bullet point form:

 

  • Install 11.2.0 RapidStart 4Tier
  • Update to 11.2.2

 

  • Try logging in, "shared memory cache" error, fixed by using this guide: Link
  • Log in successfully, create item
  • Attach WordX dataset to item revision, rich client viewer viewsthe document fine
  • Close the rich client, reboot the server

 

    • Succesfully log in, try viewing the word document
    • Teamcenter stuck in loading (bottom right progress bar)
    • Eventually the entire client window becomes "not responding"
    • I close the client and am presented with an error: 

2016-06-15 08_17_11-TC11 Testmiljö - VMware Workstation.png

 

  • Reboot the server, log in successfully again. Same problems. I noticed that I am in the "JT preview" tab when logging in, which is causing my client to crash when loading the Home folder. The embedded viewer seems to load upon login since its window and progress bars pop up momentarily.

 

  • Close client, open client, log in, now the Teamcenter client window is "not responding" before it even has a chance to load the "Home"-folder. Still on "JT Preview" tab, but no JT's to view in the "Home"-folder.
  • Now I'm "locked" outside of Teamcenter as the client keeps crashing upon logging in.
  • The gradual degrading of performance (loading/crashing) to me signifies some low system resource, or cache problem. But since I am very inexperienced with Teamcenter and am in the process of learning it, I am asking the question here in case anyone knows what I should be looking for, or what could be wrong.

I would very much appreciate some advice as to what I should be looking for or what the problem seems to be. Seems like a good learning opportunity for me!

 

Or maybe it's so bad so I need to contact GTAC?

 

Thank you Smiley Happy

6 REPLIES

Re: Need advice on troubleshooting client crash

Solution Partner Genius Solution Partner Genius
Solution Partner Genius
try to reinstall the viewer

Re: Need advice on troubleshooting client crash

Siemens Phenom Siemens Phenom
Siemens Phenom

Is your jre up to date?

 

 

jre.png

Re: Need advice on troubleshooting client crash

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Yes, the JRE is 1.7 update 79

Re: Need advice on troubleshooting client crash

Siemens Phenom Siemens Phenom
Siemens Phenom
if you delete the RAC folder in %userprofile%\Teamcenter you should at least be able to login as the JT view isn't selected anymore.
If RAC chrashs again on selecting the JT view then you can be sure that there is a problem with your visviewer installation.

Re: Need advice on troubleshooting client crash

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

I ended up doing a complete reinstall of TC Rapid Start 11.2.0, then updating it to 11.2.2. I got the "shared metadata cache" error upon logging in again, so I fixed it using the steps in the OP and I can log in, but the viewer tab has started to hang again.

 

Edit: The viewer tab is only blank for items with JT datasets attached. Word/Excel works fine and renders correctly. If I try to render a JT in the viewer tab, eventually the interface locks up somehow. I was for instance not able to access "Edit -> Options" as the client now said "Working.." in the lower left, while also stating "Working..." in the lower right for the failed viewer tab. Not touching the viewer tab for the item with a JT dataset does not cause any issues yet that I've seen. It's triggering the viewer tab that seems to cause problems.

 

Something is wrong when updating from 11.2.0 to 11.2.2, probably the way I'm updating. Right now my client window is stuck on "Working..." in the lower right, and the viewer tab is blank. The rest of the interface is responsive though.

 

To clarify (summarized) how I updated from 11.2.0 to 11.2.2:

 

  1. Download 11.2.2_install.zip and extract it. Replace the extracted files with the same files in the TC_ROOT\install directory.
  2. Run the patched TEM (the replaced file)
  3. Choose "Updates Manager"
  4. Point to 11.2.2_wntx64\wntx64 folder (the 11.2.2 update install files)
  5. Accept Data Model Updates
  6. Complete the installation and update the TC_DATA folder per instructions.
  7. Log in (now comes the "shared metadata cache" error)
  8. Fix the error, log in again
  9. Viewer tab becomes blank, client stuck on "Working..." in lower left with viewer tab open.
  10. So far I haven't been able to make the client crash by consecutively exiting and logging in again as I have before.

 

The viewer tab remains blank. So it seems something is wrong with the embedded viewer. How would I go about reinstalling it? Would it be through the corporate server TEM or the rich client TEM?

 

Thank you for your help so far.

Re: Need advice on troubleshooting client crash

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

So being perplexed I checked GTAC and found a lot of reports of this issue specific to 11.2.2 (just look at the first 5 in the list): https://solutions.industrysoftware.automation.siemens.com/result.php?sort=desc&p=1&q=embedded+viewer...

 

GTAC: 

7734634

7719533

7718396

7723261

 

So I decided to disable IPv6 using these official microsoft tools: https://support.microsoft.com/en-gb/kb/929852

 

And it worked! Items with JT file datasets attached now render properly along with everything else.

 

Hope this helps someone else out!