Cancel
Showing results for 
Search instead for 
Did you mean: 

No Server Manager (.NET) is Running!!

Valued Contributor
Valued Contributor

Experts,

 

Upgraded to TC11.4 from 10.1.7.1 

Windows server 2016 Standard, Windows 10

.NET server installed

 

I can able put login details on the web client but it says "No server manager running" and AWC(internal login error)

 

 

I reviewed TC_ROOT\net_servermanager\PoolConfiguration.xml

 
<serverManagers>
<serverManager>
<poolID>TcPoolA</poolID>
<poolPort>8087</poolPort>
<muxPort>8087</muxPort>

 

tcservermanager_log:

 

2018-01-16 11:54:59 [5] INFO Teamcenter.Enterprise.ServerManagerService.ServerManager [(null)] - Server Manager shutdown process started...
2018-01-16 11:55:00 [5] INFO Teamcenter.Enterprise.ServerManagerService.ServerManager [(null)] - Server Manager shutting down now.
2018-01-16 12:02:22 [4] INFO Teamcenter.Enterprise.ServerManagerService.ServerManager [(null)] - Server Manager Windows Service starting up.
2018-01-16 12:02:22 [6] INFO Teamcenter.Enterprise.ServerManager.StartServerPoolManager [(null)] - Server Manager starting up.
2018-01-16 12:02:30 [6] ERROR Teamcenter.Enterprise.ServerManager.ServerPoolManager [(null)] - Remoting port configured for Pool ID: TcPoolA, is already in use. Stop and start server manager on a different port. Message is: Only one usage of each socket address (protocol/network address/port) is normally permitted
2018-01-16 12:02:33 [6] INFO Teamcenter.Enterprise.ServerManager.TecsMonitor [(null)] - tecs> 2018/01/16-17:02:31,060 UTC MLD Log init: com.teamcenter.mld version V11000.2.0.50_20171201.00 (20171201)
log.properties found at C:\Apps\Siemens\Teamcenter\Teamcenter11\tc_root\net_servermanager\log.properties
INFO - NoId - 2018/01/16-17:02:33,007 UTC - tcvisdev - TECS is not running

2018-01-16 12:02:33 [6] INFO Teamcenter.Enterprise.ServerManager.StartServerPoolManager [(null)] - TECS started by .NET ServerManager. Output is written to C:\Apps\Siemens\Teamcenter\Teamcenter11\tc_root\net_servermanager\\tecs.out
2018-01-16 12:02:33 [6] INFO Teamcenter.Enterprise.ServerManager.StartServerPoolManager [(null)] - To terminate TECS, use C:\Apps\Siemens\Teamcenter\Teamcenter11\tc_root\net_servermanager\\tecsstop.bat

 

In TcWebTier log, i see an error

 

System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 10.111.1.85:8085

 

I have also uninstall/reinstall .NET Server Manager, but it did not fix

 

Is there is a mismatch of Poolport? 

 

16 REPLIES

Re: No Server Manager (.NET) is Running!!

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
PoolPort is normally 8085 and MUX port is 8087. Looks like you have a port conflict.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: No Server Manager (.NET) is Running!!

Valued Contributor
Valued Contributor

Hi Randy,

 

When I reviewed tem.bat -> webtier for .NET

 

I see port is 8085, How should i update the PoolPort?

 

Capture.PNG

Re: No Server Manager (.NET) is Running!!

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
You need to run TEM to update Server Manager and not the .NET Web Tier (which is already correct). You are looking to fix TC_ROOT\net_servermanager\PoolConfiguration.xml as poolPort is wrong:
<serverManagers>
<serverManager>
<poolID>TcPoolA</poolID>
<poolPort>8087</poolPort>
<muxPort>8087</muxPort>

Which TEM should do for you when you select the Server Manager feature.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: No Server Manager (.NET) is Running!!

Valued Contributor
Valued Contributor

I checked tem.bat-> Modify server manager peers -> Next -> 

 

Capture.PNGCapture1.PNG

 

 

Re: No Server Manager (.NET) is Running!!

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
A peer is someone you talk to. The setting you show configures the web tier to talk to server manager. It does not specify the server manager settings itself. Can you show the Feature Maintenance screen further up? It is not listed in the screen shot you provided.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: No Server Manager (.NET) is Running!!

Valued Contributor
Valued Contributor

Capture.PNG

Re: No Server Manager (.NET) is Running!!

Valued Contributor
Valued Contributor

I have re-isntalled server manager with pool port 8085, Now able to login to webclient

 

But I still have the AWC internal login error

 

Capture.PNG

Re: No Server Manager (.NET) is Running!!

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Congratulations on solving your "No server manager running" error and building the 4tier successfully (as validated by the webclient login). Now you'll have to figure out what the new error is. I don't run AW (yet), do you get an entry in a tcserver syslog?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: No Server Manager (.NET) is Running!!

Valued Contributor
Valued Contributor

I don't see syslog getting created for AWC!

 

I have attached tcserver syslog

 

Capture.PNG