Cancel
Showing results for 
Search instead for 
Did you mean: 

No email received while using EPM-set-duration and EPM-late-notification

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hi everyone,

 

I'm trying to receive an email if a reviewer task do no perform the action in a due time.

 

I'm using

EPM-set-duration

-year 0

-week 0

-day 0

-hour 0

-minute 2

 

EPM-late-notification

-recipient benjamin (benjamin is a user)

 

The problem is that I did not receive the email.

 

Do you have any idea to help me ?

 

Best regards.

7 REPLIES

Re: No email received while using EPM-set-duration and EPM-late-notification

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Do you have Task Manager installed?

 

Arden Bedell | Teamcenter Wonk | Applied CAx, LLC

Re: No email received while using EPM-set-duration and EPM-late-notification

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hello,

 

Yes I have the Task Manager services installed.

I receive notify with EPM-notify handler without problem.

 

Do you have any other recomendation ?

 

Best regards,

Re: No email received while using EPM-set-duration and EPM-late-notification

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

EPM-notify sends a message through Teamcenter mail, but EPM-late-notification sends an external email to the recipient. To make it work, you must have an email address entered for the user, and you have to set up the preferences that allow Teamcenter to connect to and send email through your company email server.

Arden Bedell | Teamcenter Wonk | Applied CAx, LLC

Re: No email received while using EPM-set-duration and EPM-late-notification

Solution Partner Genius Solution Partner Genius
Solution Partner Genius
Hello,

I receive notify with EPM-notify handler without problem in my external mail.
So the issue isn't about sending or receiving mail in an external mail.
It look likes the issue is more about setting a duration with EPM-set-duration and sending notification with EPM-late-notification.

Any other thoughts ?

Best regards,

Re: No email received while using EPM-set-duration and EPM-late-notification

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

A similar problem was reported in PR# 7447968, and the solution given was that the handler was fixed in TC10.1.4.1, TC10.1.5 & TC11.2.1. Are you using one of these releases (or later)?

 

Arden Bedell | Teamcenter Wonk | Applied CAx, LLC

Re: No email received while using EPM-set-duration and EPM-late-notification

Solution Partner Genius Solution Partner Genius
Solution Partner Genius

Hello,

 

I'm using TC 11.2.2.

 

Any other idea ?

 

Thank you.

Best regards.

Re: No email received while using EPM-set-duration and EPM-late-notification

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Hi,

 

I have the same problem with EPM-late-notification. I already have an appshare with GTAC last April and they confirmed that late notifications don't send in email. However this case still haven't been solved!! They even set it as "CANNOT DUPLICATE" 

 

(https://solutions.industrysoftware.automation.siemens.com/view.php?sort=desc&file_type=text&q=800885...)

 

I've done some experiment on this case and I came on a conclusion:

When servers for mail and teamcenter is the same, late notification is sent. But when it's not or when mail server is separated on tc, email is not sent for late nofications.

 

I have already ping this to them but i got a solution that they close it as "Cannot Duplicate"

 

I am really disappoint on this!!!! 

 

Anyway, you can do some test also with having same/different servers for mail and teamcenter. If you get the same error, kindly raise this to GTAC and mention PR 8008850. They might consider solving this on the next patch!!

 

Regards,

Lyka