Cancel
Showing results for 
Search instead for 
Did you mean: 

Parts are not opening - HTTP I/O Error, Connection Reset

Hello, 

 

We are facing strange issue, while opening items from Solidworks (SWIM 11.3.0, TC 10.1.6 - 4 tier). few of the components are not opening & throwing error, HTTP I/O Error, connection reset. It is happening only for few Assemblies & not all components are affected. I tried to open the parts on multiple systems, it is giving same error, sometimes, if I search specific item, immedietly throws connection reset error.

 

After several rounds of investigation, decided to reboot Database & App server. No change in the behaviour. 

Verified FSC service, Jboss & Pool Manager are up & ruuning.

 

Before the day, error appeared I have updated swim.properties file to avoid suppressing the components.

 

History:
While users are working with large assemblies, many of the assemblies were suppressed (even they haven't suppressed & saved in TC) & users suppose to browse for the file which is from local, as this is not loaded, users need to download solidworks data from named reference / open assembly again to load all these files, which is cumbersome effort for them to download & load. To overcome the issue, I have updated swim.properties file with iman.bom.add.suppressed = True & they continue to work.
 
Today morning they have observed that, they are not able to open & getting connection reset error. 
Please advise how to overcome this issue.