Showing results for 
Search instead for 
Do you mean 
Reply

RAC startup error after patch Tc10.1.6

I have patched Tc10.1.0 to Tc10.1.6 and the TEM installation was successful. Also patched TC_DATA after that.

 

After I start RAC and enter user credentials, the progressbar keeps running and nothing happens. The RAC log shows following error. Any idea what could be wrong ?

 

---------------------------------------------------------------------------------------------------------------------------------

 

WARN  2017-05-29 10:58:12,328 - Windows Server 2008 R2 (Service Pack 1) - win32.win32.x86_64 - null - Java(TM) SE Runtime Environment (1.7.0_25-b17) - 3.8.0.v20120529-1548
ERROR 2017-05-29 10:58:26,493 - com/teamcenter/rac/util/CipherUtil
java.lang.NoClassDefFoundError: com/teamcenter/rac/util/CipherUtil
    at com.teamcenter.rac.aif.kernel.TCSessionCredentials.setPassword(Unknown Source)
    at com.teamcenter.rac.dialogs.login.RACLoginDialog.doLogin(Unknown Source)
    at com.teamcenter.rac.dialogs.login.RACLoginDialog.access$3(Unknown Source)
    at com.teamcenter.rac.dialogs.login.RACLoginDialog$IC_KeyListener.keyReleased(Unknown Source)
    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:174)
    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1077)
    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1062)
    at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:1104)
    at org.eclipse.swt.widgets.Text.sendKeyEvent(Text.java:1704)
    at org.eclipse.swt.widgets.Widget.sendKeyEvent(Widget.java:1100)
    at org.eclipse.swt.widgets.Widget.wmKeyUp(Widget.java:1923)
    at org.eclipse.swt.widgets.Control.WM_KEYUP(Control.java:4896)
    at org.eclipse.swt.widgets.Control.windowProc(Control.java:4561)
    at org.eclipse.swt.widgets.Text.windowProc(Text.java:2570)
    at org.eclipse.swt.widgets.Display.windowProc(Display.java:4976)
    at org.eclipse.swt.internal.win32.OS.DispatchMessageW(Native Method)
    at org.eclipse.swt.internal.win32.OS.DispatchMessage(OS.java:2546)
    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3756)
    at com.teamcenter.rac.dialogs.login.RACLoginDialog.open(Unknown Source)
    at com.teamcenter.rac.dialogs.login.RACLoginDialog.initiateLogin(Unknown Source)
    at com.teamcenter.rac.aif.kernel.AbstractAIFSession.performLogin(Unknown Source)
    at com.teamcenter.rac.kernel.TCSession.performLogin(Unknown Source)
    at com.teamcenter.rac.aif.kernel.AIFSessionManager.getSession(Unknown Source)
    at com.teamcenter.rac.aifrcp.RCPPortal.login(Unknown Source)
    at com.teamcenter.rac.aifrcp.Application.runApplication(Unknown Source)
    at com.teamcenter.rac.aifrcp.Application.start(Unknown Source)
    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:353)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:180)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:629)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1414)
Caused by: java.lang.ClassNotFoundException: com.teamcenter.rac.util.CipherUtil
    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 41 more

 

 

8 REPLIES

Re: RAC startup error after patch Tc10.1.6

How did you start client ? Through portal.bat file or from TC Command Prompt ?

 

Error message gives following hint

1. The jar - com.teamcenter.rac.util.10xxxxx is not availble in your TC_PORTAL/plugins location ( OR)

2. Java is unaware of this location.

 

You can try these options:-

1. Start portal.bat file TC Command prompt 

2. In the TC Command prompt, modify the PATH and CLASSPATH variable to point TC_PORTAL/plugins location

Re: RAC startup error after patch Tc10.1.6

@rajesh_arumugam: thanks for your response. I tried starting with both, portal.bat and TC command prompt.

 

I get the same error even after setting the PATH and CLASSPATH with TC_PORTAL\plugins.

 

Plugins folder contains both jar and a folder with name com.teamcenter.rac.util.10xxxxx. The jar contains  CipherUtil.class, but not the folder.

 

RAC is started if the class file is copied to the folder or even if the .jar is extracted to overwrite the xxx.rac.util.10xxx folder, but then it gives error:

 

Could not create the view: Plug-in "com.teamcenter.rac.ui" was unable to instantiate class "com.teamcenter.rac.ui.views.BrowserSummaryViewPart".

 

 

Re: RAC startup error after patch Tc10.1.6

Hmmm.. I am seeing only jar in my plugins folder, not the folder with com.teamcenter.rac.util.10xxxx.

 

Can you try this :-

1. Make backup this com.teamcenter.rac.util folder outside TC installed directory and delete the original folder from plugins folder.

2. Clear caches, run registry and try launching Tc again.

 

 

Re: RAC startup error after patch Tc10.1.6

RAC is started after this test, but My Teamcenter shows error:

Could not create the view: Plug-in "com.teamcenter.rac.ui" was unable to instantiate class "com.teamcenter.rac.ui.views.TCComponentView".

Re: RAC startup error after patch Tc10.1.6

Does you RAC version matches with server version if you see Help--> About ? I meant, client is patched to same version of server ? 

Re: RAC startup error after patch Tc10.1.6

[ Edited ]

I am working on 2-Tier RAC from TC Server machine. once this succeeds, I will patch clients. The version however is 10.1.6

Re: RAC startup error after patch Tc10.1.6

I believe even if its Windows server and you have RAC client ( 2 Tier ), it should be patched similar to that of server. i am making this statement,  Since the problem is with jar in client sides

 

For 4 tier clients, you can create distributions and give it to all users. but how about 2 Tier client ? 

Re: RAC startup error after patch Tc10.1.6

[ Edited ]

Please correct me if I'm wrong in the following steps:

1. Installation TC10.1
During installation I selected 3 solutions: Corporate Server, Volume Server, Rich Client 2-Tier and 1 feature J2EE Server Manager. (let's call this config1)

2. Patch config1 to 10.1.6:
a. patched tem.bat to 10.1.6 using Tc10.1.6_install.zip
b. launched updated tem.bat and provided wintx64 from 10.1.6 kit and finished update
c. Patched TC_DATA to tc 10.1.6
Patch finished successfully.

3. Launched Rich-Client 2-Tier from config1 mentioned in step 1 (I mean the patched one) : This gives the error that's being dicussed here.