Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Regarding Teamcenter12 Launching issue

Legend
Legend

Hi @sam11 

 

FSC_Download error: -9009 NO_ROUTE_3{-1851658904}{volume/logvolume}{070a5cf9a1f991a1ed68}

--> something wrong with your FSC server

FileTickets::getFmsBootStrapUrls Fms_BootStrap_Urls[0]=http://usmtnasdengap02:4544

 

check  http://usmtnasdengap02:4544/Ping

 

Re: Regarding Teamcenter12 Launching issue

Legend
Legend

and open a TC command prompt and type

backup_xmlinfo -u=infodba -p=infodba -g=dba

 

this will create a backup.xml file with information about volumes

compare this information with the content of your fms master xml

 

Re: Regarding Teamcenter12 Launching issue

Builder
Builder

Hi @Roman65 

 

i have tried the solution you mentioned,

now am able to connect to DB but still am getting again "POM has not started"

i have tried.

attached is the tcserver.syslog file 

can you help me more on this.

 

Regards

Sameer Kulkarni

Re: Regarding Teamcenter12 Launching issue

Builder
Builder

Hi @Roman65 

 

also i tried through the cmd as per your solutions attached is the screenshots of refernce.

 

Regards

Sameer Kulkarni

Re: Regarding Teamcenter12 Launching issue

Legend
Legend

Hi @sam11 

 

you have an error in your DB, see part of the log below

it is the same as you had already in this post: https://community.plm.automation.siemens.com/t5/Teamcenter-Administrators-Forum/Teamcenter12-launchi...

 

Did you get an answer from GTAC?

 

INFO - 2019/06/26-07:03:18.326 UTC - NoId - Database Schema Cache Information: - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\dds\dds_io.cxx(911)
d:\workdir\tc12w0710_64\src\foundation\pom\dds\dds_io.cxxWARN - 2019/06/26-07:03:18.337 UTC - NoId - 942 - OCIStmtExecute error -1 942 "SELECT class_name, storage_mode, pname, pcpid, pproperties, ptname FROM POM_CLASS_STORAGE LEFT OUTER JOIN PPOM_CLASS ON UPPER(POM_CLASS_STORAGE.class_name) = UPPER(PPOM_CLASS.pname) ORDER BY pname" - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_enquire.cxx(2313)

DMS_cache_storage_modes
*** EIM_check_error: parse_error_offset 0

*** EIM_check_error: code -942
WARN - 2019/06/26-07:03:18.337 UTC - NoId - 545001 - (EIM_trans_util) ORA-00942: table or view does not exist
- Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_trans_util.cxx(5398)

 

Highlighted

Re: Regarding Teamcenter12 Launching issue

Siemens Phenom Siemens Phenom
Siemens Phenom

Going through this syslog ...

 

Your tcserver thinks it's running Teamcenter 12... (Line 14)

INFO  - 2019/06/26-07:03:15.917 UTC - NoId - TC_VERSION_STRING=V12000.0.0.20180710.00 - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\sss\sss_utils.cxx(464)

 

It's trying to connect to this database... (Line 25)

    TC_DB_CONNECT=infodba:L5IJ+aX9tXnHXbmfmV21Xtys8K/+mm93Oohtw/7WyLA@certdwg
    TC_DB_SERVER=usmtnasdengap01

 

You get successfully connected... (Line 203)

**** Connected to 'certdwg' as 'infodba'
DBMS Version Information:
 DBMS VERSION:: Oracle Database 12c Standard Edition Release 12.1.0.2.0 - 64bit Production
 DBMS VERSION:: PL/SQL Release 12.1.0.2.0 - Production
 DBMS VERSION:: CORE 12.1.0.2.0 Production
 DBMS VERSION:: TNS for 64-bit Windows: Version 12.1.0.2.0 - Production
 DBMS VERSION:: NLSRTL Version 12.1.0.2.0 - Production

 

But your database schema is Teamcenter 10... (Line 213)

INFO  - 2019/06/26-07:03:16.806 UTC - NoId - Database Installation Identifier: "TEAMCENTER V10000.1.0.20130604" info=00000001 - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\dds\dds_schemas.cxx(2807)

 

And tables introduced at Teamcenter 12 are missing... (Line 216)

WARN  - 2019/06/26-07:03:18.337 UTC - NoId - 942 - OCIStmtExecute error -1 942 "SELECT class_name, storage_mode, pname, pcpid, pproperties, ptname FROM POM_CLASS_STORAGE LEFT OUTER JOIN PPOM_CLASS ON UPPER(POM_CLASS_STORAGE.class_name) = UPPER(PPOM_CLASS.pname) ORDER BY pname" - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_enquire.cxx(2313)

DMS_cache_storage_modes
*** EIM_check_error: parse_error_offset 0

*** EIM_check_error: code -942
WARN  - 2019/06/26-07:03:18.337 UTC - NoId - 545001 - (EIM_trans_util) ORA-00942: table or view does not exist
 - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_trans_util.cxx(5398)

#######inside EIM_not_ok##########

sqlca_error_code is -942
EIM_db_error_code is 545001

 

 

Either you are connecting to the wrong database, or someone has restored an old Teamcenter 10 database where you expect your Teamcenter 12 one to be.

I think you need a discussion with your database admins to nail down the correct connect string, and to confirm that it is the Teamcenter 12 schema.  You can check the version string in the POM_ROOT table.

 

Re: Regarding Teamcenter12 Launching issue

Builder
Builder

Hi @jonathan_morris 

 

thank you for the wonderful information, as we did Teamcenter12 upgrade process from Teamcenter10

and before TC12 upgrade we cloned the database from our exisiting TC10 data , is it not the correct procedure 

to carryout data migration.

could you please help us how we can proceed further in resolving the issue.

 

Regards

sameer kulkarni

Re: Regarding Teamcenter12 Launching issue

Legend
Legend

@sam11 

here is some documentation to create a cloned environment for TC 10 and TC 12

 

https://docs.plm.automation.siemens.com/tdoc/tc/10.1.7/help#uid:xid1256814:index_upgrade_guide:id446...

https://docs.plm.automation.siemens.com/tdoc/tc/12.1/help#uid:xid1256814:index_upgrade_guide:id44653...

 

There is also documentation about the upgrade itself

 

You need to create a cloned environment for TC 10, and then do an upgrade on the cloned environment

BUT: before the upgrade, make sure, your cloned environment works without any problems

 

@jonathan_morris : Thanks for pointing to the right direction, 

--> But your database schema is Teamcenter 10... (Line 213)

I have overlooked the line about the DB schema

Re: Regarding Teamcenter12 Launching issue

Siemens Phenom Siemens Phenom
Siemens Phenom

If you cloned your database, then upgraded the clone then the clone database will have an updated schema, and updated data in the tables.

 

It looks like you may have upgraded the clone, but are still pointing your install to the original database.  This won't work.

 

Where I am working the normal process is to clone the database to a pre production system and use this for validating and rehearsing the upgrade process, then at go-live time the validated process is executed on the production database.

 

Re: Regarding Teamcenter12 Launching issue

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
A further observation...
@sam11, You launched a Tc10 command window which sourced your Tc10 environment then tried to source your Tc12 environment in the same command window. That's a no-no. Launch the Tc10 command window for running Tc10 commands/utilities. Launch the Tc12 command window for running Tc12 commands/utilities. You cannot combine them.

If you have trouble launching Tc12...
1. Open a normal Windows command window.
2. Drag/drop the script from C:\Siemens\Teamcenter12\tc_menu to the command window.
3. Type "set" and hit enter to validate that the command window shows TC_ settings now.
4. Run your Tc12 commands/utilities.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4