Cancel
Showing results for 
Search instead for 
Did you mean: 

Shared Metadata Cache version problem

Builder
Builder

Hi there

Today I had a problem with Shared Metadata Cache version as follow:

 

 

The Shared Metadata Cache is out of date. The dataset version 16 is older than the version 18 which is deployed in the database, so Metadata is populated locally in this process. The "generate_metadata_cache" utility will re-generate the Shared Metadata Cache.

I've used to "generate_metadata_cache" with delete and force switches but not solved.

Any sugesstion?

Thanks

 

10 REPLIES

Re: Shared Metadata Cache version problem

Phenom
Phenom

Good afternoon, try re-generate server and client caches, as example:

 

1) Delete Client Metacache
   generate_client_meta_cache -u=infodba -p=infodba -g=dba -t delete all

2) Generate Server Metacache
   generate_metadata_cache -u=infodba -p=infodba -g=dba -force

3) Generate Client Metacache
   generate_client_meta_cache -u=infodba -p=infodba -g=dba -t generate all

Re: Shared Metadata Cache version problem

Builder
Builder
Unfortunately the problem still exists. Same error after regeneration appeared.

Re: Shared Metadata Cache version problem

Phenom
Phenom

Then try this:

1) stop Server manager process and delete Shared Memory Folder
%TEMP%\V11xxxxxx

2) re-generate server and client caches from my previous post

3) Restarted Pool manager and try log to client

Re: Shared Metadata Cache version problem

Builder
Builder
Not solved. Same error again.

Re: Shared Metadata Cache version problem

Gears Phenom Gears Phenom
Gears Phenom

Is the owner of the TC folders the same as the user that is running the services? 

Re: Shared Metadata Cache version problem

Builder
Builder

Yeah, both of them are Administrator.

 

Re: Shared Metadata Cache version problem

Gears Phenom Gears Phenom
Gears Phenom

What is the user that is generate the cache? 

Re: Shared Metadata Cache version problem

Builder
Builder
This is "infodba"

Re: Shared Metadata Cache version problem

Gears Phenom Gears Phenom
Gears Phenom

Are you logged in as infodba or Administrator?

 

I had this issue but it was because of a mismatch between the installing user/ services users/ logged in user. Once that was all the same (plus turning off shared cache), then it worked after regenerating the cache.