cancel
Showing results for 
Search instead for 
Did you mean: 

Structure Manager sorting issue under the Find No. column in TC 10

Experimenter
Experimenter

Does anyone know if there is a setting for this issue? It seems to be a number of decimals issue. I've looked everywhere under Edit, Options... that I can think of. Could this be an error in the software code?

 

Here's the issue shown visually:

 

Find No. Column

M0221

M0222

M0223

M0260

M0267

M0350

 

Then it shifts the

following way down

the list...

 

M02211

M02212

M02615

M02618

M03505

 

 

It should sort like this and it doesn't since we upgraded to TC 10 from TC 9:

 

Find No. Column

M0221

M02211

M02212

M0222

M0223

M0260

M02615

M02618

M0267

M0350

M03505

2 REPLIES

Re: Structure Manager sorting issue under the Find No. column in TC 10

Valued Contributor
Valued Contributor

Skillet,

 

I used to see this sort of thing when using find numbers in the NX assembly and carried through to the drawing BOM. We were only using 2 digits with our assemblies however. I could never get it to sort properly either! until I started adding a zero before the single diget entries.

 

So find 1 became find 01, 2 became 02 etc. 01...09, then 10, 11, etc.

 

All of a sudden the BOMs read correctly.

 

May not be the answer, but it sure helped us on our way.

 

Regards

 

ionman

Re: Structure Manager sorting issue under the Find No. column in TC 10

Experimenter
Experimenter
ionman,

I appreciate your suggestion which would work, but unfortunately we would have to write a change paper to scrub the EBOM's clean for all of these production parts lists. These parts list each have upwards of 4,000 components and assemblies in them. If it's not figured out soon we may have to go with your suggestion.

Thanks for the suggestion and taking the time to respond,
Skillet