Cancel
Showing results for 
Search instead for 
Did you mean: 

TC Command line login fails

Hello Team,

 

I am able to login with TC UI it works fine, database login is also working fine.

But when I am trying to login by command line for execution of utilities like make_user, login fails.

it shows below error

 

MMAP_Memory_Pool::init_acquire: No such file or directory
(31719|140352341149248) init_acquire failed: No such file or directory
ACE_Malloc_T<ACE_MEM_POOL_2, ACE_LOCK, ACE_CB>::ACE_Malloc_T: No such file or directory
Wrong UID file format. Operation aborted.

 

I have tried to search solution in GTAC Solution center, but no luck.

3 REPLIES

Re: TC Command line login fails

Phenom
Phenom

Good afternoon
maybe you have a problem with shared cache, did you try to clean it? An example can be seen in the post:

https://community.plm.automation.siemens.com/t5/Teamcenter-Users-Forum/Getting-Error-in-Login-with-T...

 

 

Re: TC Command line login fails

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
The utility creates a syslog. Please attach it for us.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: TC Command line login fails

Hello Team,

 

The issue got resolved,

It was related to Shared Meta Cache, but even after using @ArthurRM solution it wasn't worked for me,

I have also tried to search folder V11****** but not able to locate(maybe because of Linux name will be diff)

as @RandyEllsworth suggested to look into syslog, but syslog was not generating for the utility even in tc_profilevars all settings are correctly defined, I guess syslog generated for the utility once after getting logged in by command line utility.

 

for me, it is Linux environment and below thing worked for me.

 

'ipcs -a' for listing semaphores and 'ipcrm -s semid1 -s semid2 .....' to remove them