Cancel
Showing results for 
Search instead for 
Did you mean: 

TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Valued Contributor
Valued Contributor

Hello All,

 

Greetings!!

 

I have installed TC12.2 with AWC 4.2 with Kerberos 

 

RAC and AWC Login works fine 

 

configured Visualization Server Manager for viewing JT and 3D Files.

 

Unfortunately I am getting attached error error while starting run_visservermgrError.PNG

 

i have checked D:\Teamcenter12\vispoolmanager\jetty\jettyservice.properties 

 

VisPoolProxy.localNode=DESL4CITCA04WVD:55577

 

VisPoolProxy.peerNodes=DESL4CITCA04WVD:55566

 

but still no help.

 

could you all please share your thoughts.

 

Thanks

Suresh Pandian

 

 

9 REPLIES 9

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Siemens Genius Siemens Genius
Siemens Genius

Hi,

 

In AWC is your search also working? Could you find any components?

Best regards,
Miloslav Weitz, Siemens PLM Software
Production: Teamcenter 11.5, NX 12, Geolus 9.1
Development: N/A Testing: Teamcenter 12.2, NX 1880, Geolus 10.0

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Valued Contributor
Valued Contributor

Hello  

 

Greetings!!

 

Yes I can able to search without any issues

 

AWC_Search.PNG

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Valued Contributor
Valued Contributor

Hello All,

Vis Server Manager is starting now after adding the Visualization Server Pool AssignerFeature_enabled.PNGVis_Server_Successful.PNG

 

Thank you all

 

Suresh Pandian

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
@SureshPandian, if you deploy the Vis Pool Assigner on IIS then watch for this connection situation on first startup...

ERROR : VisServerManager<node>:55577: Could not connect to VisPoolAssigner<node>:55566. Retrying ...
When viewing a JT in Active Workspace an error is displayed on the client:3D rendering is not enabled for this server
After refresh the browser the JT file was displayed without any errors.
And on the Visualization Server Manager you can see that the Vis Server is now ready:
INFO : Vis Server Manager is ready!

If you deploy Active Workspace Vis Assigner on IIS this is an expected behavior. The connection between the Visualization Server Manager and the Visualization Assigner on IIS will not complete directly. There are some option to complete this before the users tries to render JT data in Active Workspace:
1. Open the IIS Application Server Manager. Browse to your net_assigner. Select the link "Browse Application" . Web browser will start and open the requested page. Now the connection was completed. You should see for the Visualization Server Manager the message "Vis Server Manager is ready"!
2. The other way is to open a browser and enter the link to the assigner "http://localhost:8080/net_assigner/". Now the connection was completed. You should see for the Visualization Server Manager the message "Vis Server Manager is ready"!
3. If one user tries to connect the Vis Assigner by starting the Viewer in Active Workspace. This also completes the connection. And you should see for the Visualization Server Manager the message "Vis Server Manager is ready"!

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Valued Contributor
Valued Contributor

Hi Randy,

 

I have Exactly Followed the Steps. still no help . I have Craeted an IR With GTAC,

 

Capture1.PNG

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
Looks like it started successfully … not seeing your error? Let us know the resolution from GTAC.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Siemens Legend Siemens Legend
Siemens Legend
One way to deal with this really annoying problem is to use some tool like wget, or curl, or a small python script or such to send a HTTP request to that net_assigner address. Put it in the Vis Server Manager start script.

This way the net_assigner application is always initialized before the Vis Server Manager runs.

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Valued Contributor
Valued Contributor

Hello TheGAP,

 

Greetings!!

 

Thanks a lot for the wonderful Idea :-)

 

Thanks 

Suresh Pandian

Re: TC12.2/AWC 4.2 - Visualization Server Manager :- Could not connect to VisPoolAssigner

Valued Contributor
Valued Contributor

Hello All,

 

Issue has been resolved after disabling IPV6.

 

Please add the below registry

 

"HKLM\System\CurrentControlSet\Services\TCPIP6\Parameters"

Create New Entry ---> DisabledComponents=32"2

JT_AWC_Working.PNG

 

 

Thanks