Cancel
Showing results for 
Search instead for 
Did you mean: 

Team center EngineeringUtilityException:POM002

Experimenter
Experimenter

Hi,

 

while installing Teamcenter 10.1.5 on windows 8, i got this error related to Engineering utility exceptionSmiley TongueOM002 ......so please can anyone suggest a solution for this .......

 

 

7 REPLIES

Re: Team center EngineeringUtilityException:POM002

Creator
Creator

Take a look in the installations log and try to find out what command that is failing.

I have got the same error on some test installations, in that cases the problem was possible to resolve by reading installationlog and command-log.

 

Can you dig a little deeper into the logs and maybe post some extract of the logs?

 

 

Re: Team center EngineeringUtilityException:POM002

Experimenter
Experimenter

Hi,

 

Thankyou for reply ...

 

Here are some details of the log files, just see if you can suggest a solution from these details.....

Re: Team center EngineeringUtilityException:POM002

Legend
Legend

Can you upload complete log? 

Please check once you are pointing to correct license server?

Re: Team center EngineeringUtilityException:POM002

Experimenter
Experimenter

Hi,

The error is solved now, i just reinstalled the license server.

Thankyou for ur suggestions ...

Re: Team center EngineeringUtilityException:POM002

Experimenter
Experimenter

Hi,

     I am trying to install Teamcenter 11.2. During installation I got the same error as "EngineeringUtilityExceptionSmiley TongueOM002".When I saw in install_config log file, it is failing to run the "bmide_schema ALL"utility.

I ran that BMIDE schema ALL utility manually by setting the Teamcenter environment variables. It generated a syslog file with the following message,

                           License Error: -39

                          DEBUG - 2018/02/23-13:44:08.646 UTC - NoId - Flexlm attach error:  -39:               User/host not on INCLUDE list for feature.

 

But, when I try to ping to that license server, it is pinging.

Here, I have enclosed install_config log file.        

Please can anyone suggest a solution for this. Thank you.

Re: Team center EngineeringUtilityException:POM002

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Some folks will have this while other folks won't. A modification needs to be made to the license file to resolve this issue.

The INCLUDE statement is required for USER_BASED or HOST_BASED features. You can validate your situation by searching the license file for INCREMENT lines that contain USER_BASED or HOST_BASED. For instance, mine shows:
INCREMENT TCDIST ugslmd 14.0 30-nov-2018 30 USER_BASED SUPERSEDE \

To resolve the error, you have to add an "options" file by adding the OPTIONS switch to the VENDOR line. Mine:
VENDOR ugslmd OPTIONS=C:\Siemens\PLMLicenseServer\ugslmd.opt PORT=28005

In C:\Siemens\PLMLicenseServer\ugslmd.opt:
# Declare a GROUP of users
GROUP sdi Administrator infodba ed cadguy
# INCLUDE all users in GROUP
INCLUDE TCDIST GROUP sdi

Restart Flexlm after making these changes and review the splm_ugslmd.log for errors.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Team center EngineeringUtilityException:POM002

Experimenter
Experimenter

Hi Randy,

     Thanks for reply, my license server was in some other city, that was using by group of users, for most of folks it is working fine like you said. My license file and Flexlm was not in my system, it is all in there server side.

 

     By downloading lmutil.exe from https://www.techniatranscat.com/support/downloads/flexnet-publisher., I tried to ran the below command to check whether daemon in license server up or user has access to license server,

lmutil.exe lmstat -c 28000@<IP address>

lmutil.exe lmstat -c 28000@<IP address> -f <user name>

 

In that I got error message as lmgrd is not running: License server machine is down or not responding. (-96,7:11001 "WinSock: Host not found").

Please suggest a solution for this. Thank you.