Cancel
Showing results for 
Search instead for 
Did you mean: 

Teamcenter 11.2.2 SaveAs/Revise Issues

Creator
Creator

Recently went to Teamcenter 11.2.2.1 from TC 10.1.6.1. Now I am unable to do a save as on any item type or revise an item revision. There is some issue with action rules needing to be converted to extension rules. Anyone else having this problem? Any idea on how to convert between the two? Anyone know what action rules or extension rules are to begin with?

4 REPLIES

Re: Teamcenter 11.2.2 SaveAs/Revise Issues

Genius
Genius

What is the error message you are getting?

 

We had similar issue when we upgraded. Our revise operation was failing with error "object cannot be based on multiple WSO...". It was a big showstopper issue. This was basically coming from deep copy rules on our custom ItemRevision object. We had "MatchAll" relation in the rule. Issue was solved after changing it to "IMAN_Specification"

Re: Teamcenter 11.2.2 SaveAs/Revise Issues

Creator
Creator

The error we are getting is "Attempt to free already free block" when doing a revise or save as. At least that is what the syslog and rac log says. The actual error in teamcenter says something generic like "Failed to create business object". It appears to be some sort of memory allocation issue? However after talking to GTAC for several days they believe it is an issue with action rules that need to be converted to extension rules. The problem is, I cannot find any documentation related to what action or extension rules are, and how to convert from one to the other.

 

We definitiely are not getting the same error message you were. 

That being said, I just checked bmide for our deep copy rules on item revisions. I see match all under the attached business object (see screenshot). Is that what you changed?

Re: Teamcenter 11.2.2 SaveAs/Revise Issues

Genius
Genius
Your error message definitely sounds different that ours.
Our problem was 'MatchAll' on 'CopyAsObject Action' on custom ItemRev.

Re: Teamcenter 11.2.2 SaveAs/Revise Issues

Creator
Creator

No, but the solution was something similar. We changes to ItemRevision operations Item_copy_rev and Item_copy_rev_to_existing. We had to add the Pre Condition checkLatestReleased to both of those operations. It seems like this is an issue that comes from legacy Action Rules that were never removed from back when we started using Teamcenter 2005.

 

Thank you for your help though. It did end up being a BMIDE fix, but just not the same fix as what you proposed.