Cancel
Showing results for 
Search instead for 
Did you mean: 

Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

I installed Tc 11.6 server with 2 tier RAC with AWC 4.1 successfully. I could login to 2T RAC and AWC without issues.

 

But login to 4-Tier RAC gives error "null". Any idea about this issue ?

 

Below is RAC log.

 

WARN  2019-01-22 10:51:33,855 - Windows 10 () - win32.win32.x86_64 - null - Java(TM) SE Runtime Environment (1.8.0_171-b11) - 3.8.0.v20120529-1548
ERROR 2019-01-22 10:51:56,200 - null: null
null
    at com.teamcenter.rac.kernel.TCSession.handleException(Unknown Source)
    at com.teamcenter.rac.kernel.TCSession.startTCSession(Unknown Source)
    at com.teamcenter.rac.kernel.TCSession.login(Unknown Source)
    at com.teamcenter.rac.kernel.TCLoginJob.run(Unknown Source)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: com.teamcenter.schemas.soa._2006_03.exceptions.InvalidCredentialsException: null
    at com.teamcenter.soa.internal.client.ExceptionMapper.parseExceptionString(Unknown Source)
    at com.teamcenter.soa.internal.client.ExceptionMapper.parseExceptionString(Unknown Source)
    at com.teamcenter.soa.internal.client.XmlRestSender.invoke2(Unknown Source)
    at com.teamcenter.services.loose.core.SessionRestBindingStub.login(Unknown Source)
    ... 4 more

 

17 REPLIES 17

Re: Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Hi @Amol_XPLM ;

 

That issue is valid for all TC users or just one user ? Also did you check it on the server machine ?

Did you install the dispatcher services ? Also could you share syslog and rac log as attached please ?

 

Best Regards

Gurkan

Re: Teamcenter 11.6 login issue on 4Tier

Pioneer
Pioneer

Maybe I do not understand something, but you created and deployed tc.war for 4 tier ?

Re: Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Thank you for the reply @GurkanAlkan and @luckysever.

 

Login on server (2Tier), login on AWC works fine. I also have deployed tc.war. I will check TcServer syslog.

 

Re: Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend
The issue occurs for all users.

I have installed Dispatcher services. Does this have any effect ?

I will check server syslogs, I haven't yet.

RAC log contains only the stacktrace which I posted in my first post of the thread.

Re: Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Hi @Amol_XPLM ;

If there is a problem with the tc.war or awc.war deployment you can not log in the AWC. Yes maybe syslog can be give more information to solve it. If you catch the solution could you share it please ?

 

Best Regards

Gurkan

Re: Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Hi @Amol_XPLM ,

 

I'm not sure Dispatcher services effects it directly , but according to the your shared screenshot , i search a error line in GTAC then i saw that , generally all the topics are related about the dispatcher services . Unfourtunally , i was not able to check the detail of these calls. If you will share the syslog , i can check also.

 

Best Regards

Gurkan

Re: Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

@GurkanAlkanas login itself is not working, there's no syslog created for the session.

I also tried login with webclient and it worked. That means tc.war is also fine.

Only 4-Tier RAC is the problem.

Re: Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Did you installed it Java Base or .net base ? If the users can log in the AWC (which use 4 Tier ) , also you can log in 4 Tier because they are use same background. Then i think , when you log in the AWC with any user , the syslog may be created.  If you are installed it with JBOSS base , in the services of the standalone , did you see that , deployment is done succesfully ?

 

Best Regards

Gurkan

Re: Teamcenter 11.6 login issue on 4Tier

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

I have installed Java based server manager and I use Weblogic app server.
AWC session creates a syslog. I have attached it here.