cancel
Showing results for 
Search instead for 
Did you mean: 

Teamcenter 2-tier installation error

Pioneer
Pioneer

I could see an error " could not to the server" while launching 2-tier Teamcenter. I did check the TAO window,it shows following error.

 

 

Checking for currently running TAO ImR services...
No running TAO ImR services found...
1 file(s) copied.
Starting ImplRepo service...
Implementation Repository: Running
Ping Interval : 10000ms
Startup Timeout : 60s
Persistence : C:\Users\rabdul\Teamcenter\TAO\tcserver.xml
Multicast : Disabled
Debug : 2
Locked : False

Starting ImR Activator...
ImR Activator: Starting localhost
ImR Activator: Contacting ImplRepoService...
ImR: Activator registered for localhost.
ImR Activator: Registered with ImR.
ImR Activator: The Activator IOR is: <IOR:010000002b00000049444c3a496d706c656d656e746174696f6e5265706f7369746f72792f416374697661746f723a312e300000010000000000000090000000010102000c00000031302e31352e302e323535007ace00003e00000014010f004e55500000001e0000000001000000526f6f74504f4100496d525f416374697661746f72000000000001000000496d525f416374697661746f7200000200000000000000080000000161b502004f415401000000180000000161b5020100010001000000010001050901010000000000>
Starting TcServer TcServer1...
Warning: The activate option has been renamed to start.
ImR: Manually activating server <TcServer1>
ImR: <TcServer1> not running. alive=false.
ImR: Starting server <TcServer1>. Attempt 1/1.
ImR Activator: Starting server <TcServer1>...
command line : <C:\TcApps\Siemens\2T\Local\iiopservers\start_TcServer1.bat>
directory : <C:\TcApps\Siemens\2T\Local\iiopservers>
ImR Activator: register death handler for process 8980
ImR Activator: Successfully started <TcServer1>, pid=8980
ImR: Waiting for <TcServer1> to start...

Exception caught while parsing the file C:\TcApps\Siemens\tcpro\tc_solutions_preferences.xml at line : 0.
PREF_report_error_version_missing

PREF_report_operation_failed


Exception caught while parsing the file C:\TcApps\Siemens\tcpro\tc_preferences.xml: 'PREF_report_operation_failed'
ImR: Server TcServer1 is running at corbaloc:iiop:1.2@10.15.0.255:52878/.
ImR: Server TcServer1 callback at IOR:010000002e00000049444c3a496d706c656d656e746174696f6e5265706f7369746f72792f5365727665724f626a6563743a312e3000000001000000000000006c000000010102000c00000031302e31352e302e323535008ece00001b00000014010f00525354cf5ad659d5f10d00000000000100000001000000000200000000000000080000000101f001004f415401000000180000000101f0010100010001000000010001050901010000000000.

ImR: Connected to server <TcServer1>

******************************************************
* *
* Preparing to start Teamcenter Server. *
* ImR: <TcServer1> Ping timed out, maybe completed. alive=true.
ImR: Successfully activated <TcServer1> at
corbaloc:iiop:1.2@10.15.0.255:52878/
Successfully Activated server <TcServer1>
*
******************************************************

 


******************************************************
* *
* TcServer1 Ready *
* *
* *
******************************************************


ImR: Activating server <TcServer1>.
ImR: <TcServer1> Ping successful. alive=true
ImR: Successfully activated <TcServer1> at
corbaloc:iiop:1.2@10.15.0.255:52878/
ImR: Forwarding invocation on <TcServer1> to <corbaloc:iiop:1.2@10.15.0.255:52878/TcServer1>

 

" I did check the xml in TC_DATA C:\TcApps\Siemens\tcpro\tc_solutions_preferences.xml , it exists and I do have full control access as well". Any suggestions how to proceed further?

22 REPLIES

Re: Teamcenter 2-tier installation error

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

In my Tc11.3 environment, the tc_solutions_preferences.xml file shows this line:

 

<preferences version="10.0">

 

Does your file have a similar line?

Arden Bedell | Teamcenter Wonk | Applied CAx, LLC

Re: Teamcenter 2-tier installation error

Pioneer
Pioneer

I am using 10.1.7.1, I checked the tc_solutions_preferences.xml file

 

It shows Line 13:  <preferences version="10.0"> 

Re: Teamcenter 2-tier installation error

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

The error message shows this path to the tc_solutions_preferences.xml file:

 

C:\TcApps\Siemens\tcpro\tc_solutions_preferences.xml

 

Is that where you've put tcdata, and where the file can be found?

Arden Bedell | Teamcenter Wonk | Applied CAx, LLC

Re: Teamcenter 2-tier installation error

Pioneer
Pioneer

Yes, the path is valid and I can see that tc_solutions_preference.xml file also.

Re: Teamcenter 2-tier installation error

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

I don't see anything on the GTAC solution site about an error like this. I guess you'll have to contact GTAC for help to sort it out.

Arden Bedell | Teamcenter Wonk | Applied CAx, LLC

Re: Teamcenter 2-tier installation error

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor
I have faced the same error while starting pool manager and I found that the error is misleading. Replacing the XML with a valid one (from other working envt of the same version) also showed the same error.
But then I found FMS_HOME was wrongly set and error did not occur after correcting it.
So I would suggest to check if all values like FMS_HOME, TC_ROOT, TC_DATA etc. are set correctly.

Re: Teamcenter 2-tier installation error

Pioneer
Pioneer

Do you want me to check on tc_profilevars.bat file in TC_DATA, how FMS_HOME and TC_ROOT is set?

Re: Teamcenter 2-tier installation error

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
I would check the environment variable for FMS_HOME or foricibly set it correctly in portal.bat by removing the "if not defined FMS_HOME" portion of the line. Then check the files in iiopservers for TC_ROOT and TC_DATA.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11.0.1.mp01 | SW 2016 | TcUA 11.2.3
Evaluating:AW 3.2

Re: Teamcenter 2-tier installation error

Pioneer
Pioneer

Hi Randy,

 

I did foricibly set FMS_HOME in portal.bat and removed if not defined

 

I also checked "start_imr.bat" and "start_TcServer1.bat" in iiopservers, TC_ROOT and TC_DATA are pointing to the correct path! I still get the same error when I start portal.bat, no change