cancel
Showing results for 
Search instead for 
Did you mean: 

UGMANAGER_CLONE import not working!

Experimenter
Experimenter

Hi All,

 

I could not execute ugmanager_clone import option, i am facing an error "Teamcenter Integration is not initialized while initializing import operation", Please find the attachment for snap.

 

i have gone through a similar issue posted in this community page, but not solved fully.  

Thanks in advance.

 

-AJ

-AJ
2 REPLIES

Re: UGMANAGER_CLONE import not working!

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

I don't see the "-pim" argument in your command line. The NX help docs show this example:

 

ugmanager_clone -pim=yes -u=<userid> -p=<password> -g=<group> -o=import -par=12345_A.prt
-default_n=autotranslate

 

Arden Bedell | Teamcenter Wonk | Applied CAx, LLC

Re: UGMANAGER_CLONE import not working!

Experimenter
Experimenter

Hi ardenb, 

 

Thank you for the reply. 

 

I tried using -pim=yes , here the problem was LDAP/SSO .. i was using tc login credentials instead of SSO login credentials.

 

Moreover the ugnx document says, ugmanager_clone forces -pim=yes , thats the reason. i have not used -pim tag.

 

Any how the solution here is "Use SSO credentials

 

Please find below for the UGNX document says about ugmanager_clone script, 

 

"ugmanager_clone script

ugmanager_clone is a script which wraps around the ug_clone utility, ensuring that the correct Teamcenter environment is set up and forcing the -pim=yes argument.

 

The ug_clone utility can be called from either native NX or from Teamcenter Integration. Calling this utility from Teamcenter Integration requires that the Teamcenter environment be set up. Using the ugmanager_clone script eliminates the need for this step."

 

-AJ

-AJ