Cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrade TC10.1.3.1 to 11.6 - Problems with deploying SSO War files

Creator
Creator

Hello all,

 

I'm after some advice as always please.

 

We're currently upgrading from TC10.1.3.1 to 11.6. I am now at the stage where I am trying to deploy the .war files generated through insweb.bat to get SSO working.

 

We were using Apache Tomcat 6 but I have upgraded to 8.5.

 

I have generated my tcidentityservice and tcloginservice .war files and deployed through Tomcat and set up the Teamcenter Security Services through tem. When I browser to http://server:8180/tcloginservice I get the Siemens login page where I can press Enter Teamcenter, enter a username and password and get the following error:

 

There is a system error. Please contact your system administrator.

org.apache.xmlrpc.client.XmlRpcHttpTransportException: HTTP server returned unexpected status: null

 

If I try to browse to http://server:8180/tcidentityservice I get:

 

HTTP Status 404 – Not Found


Type Status Report

Message /tcidentityservice/

Description The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

 

I am hopeful someone may be able to tell me where I am going wrong as I have absolutely 0 experience in deploying webapps or using Tomcat.

 

Thank you

5 REPLIES 5

Re: Upgrade TC10.1.3.1 to 11.6 - Problems with deploying SSO War files

Valued Contributor
Valued Contributor
Hello Matthew,

What is the output of
http://server:8180/tcidentityservice/xmlrpc

Thank You

Re: Upgrade TC10.1.3.1 to 11.6 - Problems with deploying SSO War files

Creator
Creator

That page doesn't load, generates the error below:

 

HTTP Status 500 – Internal Server Error Type Exception Report Message Servlet.init() for servlet [ssoservice] threw exception Description The server encountered an unexpected condition that prevented it from fulfilling the request. Exception javax.servlet.ServletException: Servlet.init() for servlet [ssoservice] threw exception org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:493) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:81) org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:650) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:342) org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:800) org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66) org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:806) org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1498) org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49) java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) java.lang.Thread.run(Thread.java:748) Root Cause java.lang.NullPointerException com.teamcenter.ss.identity.spi.SSOLDAPConfig.init(Unknown Source) com.teamcenter.ss.identity.spi.SSOLDAPContext.init(Unknown Source) com.teamcenter.ss.identity.spi.LDAPIdentityProvider.init(Unknown Source) com.teamcenter._ss.service.SSOServiceImpl.initialize(Unknown Source) com.teamcenter._ss.service.SSORequestHandler.(Unknown Source) com.teamcenter._ss.service.SSOServlet.init(Unknown Source) javax.servlet.GenericServlet.init(GenericServlet.java:158) org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:493) org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:81) org.apache.catalina.valves.AbstractAccessLogValve.invoke(AbstractAccessLogValve.java:650) org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:342) org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:800) org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66) org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:806) org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1498) org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49) java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) java.lang.Thread.run(Thread.java:748) Note The full stack trace of the root cause is available in the server logs.

Re: Upgrade TC10.1.3.1 to 11.6 - Problems with deploying SSO War files

I think the identity service is not able to point "Authentication Provider". 

You will have to cross check the parameters you have provided while configuring the identity service. 

 

 

Regards,

Ganesh

Re: Upgrade TC10.1.3.1 to 11.6 - Problems with deploying SSO War files

Creator
Creator

Thanks Ganesh!

 

Do you happen to know which bit the authentication provider resides in within insweb please? Just had a look through and can't see one with that name.

 

 

Re: Upgrade TC10.1.3.1 to 11.6 - Problems with deploying SSO War files

when you run insweb for creation & configuration of identityService..

 

if you are using LDAP as third party Authentication, then in LDAP Configuration Table we need to provide details about the LDAP server..

 

as shown in below image..

 

Capture.PNG