Cancel
Showing results for 
Search instead for 
Did you mean: 

User not able to launch NX11 After TC 11.3 Patch deployment

Pioneer
Pioneer

Hello Experts

 

we deploy TC SSO with OAUTH and TC 11.3 Patch, now all the users within company and supplier are able to login and work on TC post deployment.

 

Now one paerticular supplier, The user not able to NX from TC 4TRC, he is able to login to TC

 

  1. User use nodelocked local license
  2. Able to launch NX native
  3. Was able to launch NX from TC before New Patch
  4. Post patch deployment he is not able to launch NX from TC

Once he click on NX icon from TC menu it error out with below message

 

Spoiler
Authorization error: invalid host. The system's host ID does not match the host ID specified in the license file. [ -9 ]

Then in NX syslog file the error is like below

 

Spoiler
No license available.
If you want to use binding package, please confirm
Set UGII_FLEX_BUNDLE correctly.

we ahve enough TC licenses and NX manager licenses, the license server log doesnt show any exeptions

 

Any help is appreciated

 

Thanks

6 REPLIES

Re: User not able to launch NX11 After TC 11.3 Patch deployment

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Your new version of Teamcenter requires that NX be licensed from the same file. You cannot run "local" NX licenses without having TC30600 in your Teamcenter license:
"The NX Integration with Teamcenter delivered with NX Mach products are packaged to work in an environment where the Teamcenter and NX license servers are on the same machine. If a customer intends to work with a centralized Teamcenter license server and local NX license servers they must purchase the NX Embedded client (TC30600) for the centralized Teamcenter license server."

The supplier will need to change their SPLM_LICENSE_SERVER environment variable to point to your license server or you will need TC30600 in your file to allow them to work locally. Hope that helps.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: User not able to launch NX11 After TC 11.3 Patch deployment

Pioneer
Pioneer
hello Randy

Thanks for reply

we had TC 11.2.3 earlier and were able to run without any issue, is it introduced post 11.3?, because we have other suppliers who have their own NX licenses and are able to connect to TC+NX post 11.3

Thanks

Re: User not able to launch NX11 After TC 11.3 Patch deployment

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
The requirement has been in place for awhile but wasn't enforced. To find out when enforcement was put in place you'll need to contact GTAC. Although my suggestion sounds like the cause of your error, maybe it isn't.

You can also try resetting his NX cache...
- Log out of TC and NX (kill any java.exe processes).
- Rename the folder C:\Users\%USERNAME%\AppData\Local\Siemens\NX110
- Launch TC and NX

Or compare his license against another supplier that doesn't have this issue? Another possibility is that this supplier has a node-locked license (not floating). For node-locked licenses the hostid can be the disk serial number of the C drive, or the MAC address of an Ethernet adapter. The hostid in the license file must be visible on their system at all times. There are several possible reasons why the hostid might not match:
- Typing error while registering your serial number.
- The hostid of the system has changed (e.g. due to replacing the Ethernet adapter)
- Trying to use the license file on a different machine

References:
http://www.harrisgeospatial.com/Support/SelfHelpTools/HelpArticles/HelpArticles-Detail/TabId/2718/Ar...
http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.faqs/ka4128.html

Keep us posted on your findings as others could have this error too.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: User not able to launch NX11 After TC 11.3 Patch deployment

Pioneer
Pioneer

Hello Randy, Thanks a lot for follow up

 

Things working nows, but we are still wondering what was the exact issue

 

 

 

Spoiler

Scenario 1, Things didnt work after 11.3 patch (Location: SUpplier in Asia, connecting to TC 4T through our firewall), using their local NX licenses

 

NOt worked, here is teh ifnormation NX syslog

************** Licensing Information **************

Sold To / Install : 55555555 - ABC COMPANY
Webkey Access Code : XXXXXX
License File Issuer : SIEMENS
Flexera Daemon Version : 0.0
Vendor Daemon Version : No Version
Toolkit Version : 8.2.1.4
Server Setting Used : C:\Windows\Temp\License_Ugslmd.txt
Server Setting Came From The 'SPLM_LICENSE_SERVER' Environment Variable.

Number of bundles in use : 1
Bundle [ 0 ] : NX11100N
Bundle Setting Came From The 'UGS_LICENSE_BUNDLE' Environment Variable.

***************************************************

Scenraio 2, Thnigs worked, after we commented their SPLM_LICENSE_SERVER variable on user deskptop

 

Spoiler
Information from current NX syslog, after we disbaled the SPLM variable
************** Licensing Information **************

Sold To / Install : XXXXXX- SIEMENS PLM SOFTWA
Webkey Access Code : XXXXXXXX
License File Issuer : SIEMENS
Flexera Daemon Version : 11.13
Vendor Daemon Version : 8.2
Toolkit Version : 8.2.1.4
Server Setting Used : 28000@10XXX1422XXX61
Server Setting Came From The 'SPLM_LICENSE_SERVER' Environment Variable.

Number of bundles in use : 1
Bundle [ 0 ] : NX11100N
Bundle Setting Came From The 'UGS_LICENSE_BUNDLE' Environment Variable.

***************************************************

Only diff i notice is, earlier it seems like was using local license and when we disbaled its connecting to a floating license server??

 

but same was working at TC 11.2.3, and no issue till 11.3 was deployed.

Re: User not able to launch NX11 After TC 11.3 Patch deployment

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
You can see in the spoilers that the failed attempt was trying to access a node-locked license (no flex version) and in the successful attempt it is accessing the corporate license (flex version shown). I believe the supplier is accessing your corporate license and not a local license as you've stated in the diff comment. You can validate if this supplier is taking a license for NX from the corporate pool by reviewing the flexlm log on the corporate license server.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: User not able to launch NX11 After TC 11.3 Patch deployment

Pioneer
Pioneer

Thanks Randy,

 

I the the licenser server its pointing at in the log file is suppliers flex lic, since we have blocked our 28000@Server in firewall for supplier access.

but yeah i will check in NX licenses are getting checked from Flex pool