Cancel
Showing results for 
Search instead for 
Did you mean: 

pool manager issue

Genius
Genius

Hello;

I have testing pool mangaer settings on my env and after changing pool manager settings through TEM I can not connect to it. I  changed  some treecache peers chenges and also some modification into PROCCESS_TARGET settings.

I removed the pool maneger and installed it again but the issue is not solved. I attached the images below.

I apperciate you help.

 https://mega.nz/#!fBQAVSLK!IevY8_f8aaYgymyJY79enLSgZYchOUlJZi_KqrsSNeA

 https://mega.nz/#!yFAgnIAA!I49jASxuNvbuuCIKv20KdgYL5n7DaqvXwpT_9ielR5o

BR.

7 REPLIES 7

Re: pool manager issue

Gears Phenom Gears Phenom
Gears Phenom

Good afternoon, there is no attached image.

Re: pool manager issue

Genius
Genius

@ArthurRM wrote:

Good afternoon, there is no attached image.

Hello & good afternoon.

Excuse me I couldn't attach the images directly with jpeg format so I uploaded them and the links are attached now.

 

Thanks.


 

Re: pool manager issue

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
After making changes to Pool Manager (J2EE), I assume you restarted the service but did you also restart your WebTier (J2EE) so that the shared TreeCache between them is in sync?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: pool manager issue

Genius
Genius

@RandyEllsworth

Hello;

I restarted the weblogic even reinstalled it but no difference.

Re: pool manager issue

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
Then the problem is with the Pool Manager treecache configuration and not that the WebTier had stale info. You'll have to share your config with us.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: pool manager issue

Genius
Genius

Thanks @RandyEllsworth

I inspected the configuration and it seems to be ok, both manager and web application on a machine and set treecache ports 17800 and 17810 back and forth. I think because I was testing and changed the settings too many times It mixed up, maybe something is cached .... where can I remove the cache completely (related to manager)?

 

BR.

Re: pool manager issue

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
By stopping Pool Server Manager and Web Tier (clears the TreeCache) then starting Pool/Server Manager followed by the Web Tier (establishes the TreeCache). Instead of changing settings directly in the files when developing, you can change settings dynamically using the JMX console (or Teamcenter Management Console for Tc11.2.3+). When you're happy with the settings then you can modify the files for a more permanent resolution.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4