Cancel
Showing results for 
Search instead for 
Did you mean: 

remote cache server shows its not caching - how do I verify

Pioneer
Pioneer

We are using Teamcenter 10.1.7 on Windows 2008.

 

We have a master fsc process in NA (not a cache server). There is a remote FSC server in Asia-Pacific. That remote fsc is setup as store and forward volume server as well.

 

There is  almost 10GB data stored in remote store and forward volume server. But that doesn't seem to be cached. Running fscadmin shows very few files (with lot of misses). I have attached the screenshot showing output of fscadmin utility.

 

How do we verify if its caching the data if fscadmin is not right tool to track that?FscAdmin_RemoteServer.png

34 REPLIES

Re: remote cache server shows its not caching - how do I verify

Solution Partner Honored Contributor Solution Partner Honored Contributor
Solution Partner Honored Contributor
There could be a lot of reasons for the results you're seeing. A miss just means that it didn't find the file in the cache. You could also be allowing direct communication with the volume thereby skipping the cache. There are settings to force caching. By default the FSC read and write magic five settings are really small which are appropriate for Dev but not for Prod - you use the TC_ROOT\bin\FMSCacheSizingTool_Ver_1_3.zip to find the "tuned" settings.

If you want to attach your FMS Master and the FSC xml's for NA and AP then I can make better recommendations.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: remote cache server shows its not caching - how do I verify

Pioneer
Pioneer

Sorry for the delayed response - I was off couple days. Really appreciate your response.

 

Here is the files. It seems I can attach only one file with one post- will add fsc in next post.

 

Also, how do I make sure adding a local volume doesn't cache - is there a configuration to force it to cache?

Re: remote cache server shows its not caching - how do I verify

Pioneer
Pioneer

Re: remote cache server shows its not caching - how do I verify

Solution Partner Honored Contributor Solution Partner Honored Contributor
Solution Partner Honored Contributor

I've modified the FMS Master:

  1. Added fscdefault section.
  2. Added fccdefault to disable direct routing.
  3. Added exitfsc for each group to cache files when they leave the group. Note: you can also add entryfsc if needed.
  4. Changed "mygroup" to "CORP" for clarity.
  5. Added linkparameters to link all the groups. Note: maxpipes can be increased/decreased based on WAN conditions.

Compare this one to yours and you should be able to see the differences. I encourage you to research the settings.


Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: remote cache server shows its not caching - how do I verify

Pioneer
Pioneer

Thanks much for the updates to fmsmaster. I will research on few things you have added there. As specially FSC_DoNotCompressExtensions & exitfsc.

 

I really appreciate it. This will surely be a good starting point for us.

Re: remote cache server shows its not caching - how do I verify

Pioneer
Pioneer

A quick one -

 

Is there any relation between settings on FSC_DoNotCompressExtensions/linkparameters and FCC_EnableDirectFSCRouting?

 

I think there isn't but validating with the experts if I HAVE to set compression & wan settings while disabling the direct routing.

 

Thanks much!

Re: remote cache server shows its not caching - how do I verify

Solution Partner Honored Contributor Solution Partner Honored Contributor
Solution Partner Honored Contributor
The linkparameters allow the groups to talk between each other. You can create more of a hub and spoke design by only having the "CORP" linkparameters (to and from) but then a file modified in the UK and a user trying to access it in Sweden has to take extra trips.

The donotcompress simply prevents compression on already compressed files (performance).

DirectRouting allows clients to write directly to volumes without talking to their cache so that's a critical element. You don't have to set compression but its a good idea for performance. In fact, you could set all the FSC's to lan (default) instead of wan.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: remote cache server shows its not caching - how do I verify

Pioneer
Pioneer

So rather than chaning the fmsmaster file, I have set FCC_EnableDirectFSCRouting to false in fcc.xml on one of the Asia Client PC. This way I can validate it on client first rather than making a change on global file.

 

Loaded a file, imported a text file, created a new dataset with text file. None of these have had any impact on the FSCCacheLocation read/write folders/files. The date stamp on those fsc files didn't change.

Re: remote cache server shows its not caching - how do I verify

Solution Partner Honored Contributor Solution Partner Honored Contributor
Solution Partner Honored Contributor
I don't see a FSC group for "Asia" clients in your FMS Master? How do you know which FSC they are supposed to be talking to? What's the IP address of the Asia client? If the IP doesn't fall within any of the ranges outlined in clientmap then they will talk to FSC_IAC_PDMPW01_svc_PLMAdmin (127.0.0.1).

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4