Cancel
Showing results for 
Search instead for 
Did you mean: 

Active Workspace 3.3 Install Error: generate_metadata_cache

Siemens Creator Siemens Creator
Siemens Creator

Hello,

 

I am running into an error message during the Active Workspace patch install for Teamcenter 11.2 that says:

 

Installation interrupted due the following reason:

UPDATE MANAGER FAILURE: PatchingAction: Patch task failed while processing feature, 'Teamcenter Foundation': The following command returned a value of 14112
"generate_metadata_cache" -u=infodba -p=***** -g=dba -force

 

 

This is in the error message in the generate_metadata_cache log:


--------------------------------------------------------------------------------
Command output for the generate_metadata_cache

--------------------------------------------------------------------------------
Log File Name : C:\Temp\generate_metadata_cache.log
Force generate cache : true

--------------------------------------------------------------------------------
Building shared metadata cache...
MetadataVersion::makeCacheDataset failed with 14112.

 

 

I have attached a photo of the error message and the logs. I have also tried restarting the services and regenerating the cache with no luck and still getting the same error message.

 

I also tried to log on to Teamcenter and got a different error, but it relates back to the generate_metadata_cache and i included the picture of that message as well.

 

Please let me know any solutions that might resolve this error.

 

Thanks!

17 REPLIES

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
There should be a generate_metadata_cache.syslog in TC_TMP_DIR or TC_ROOT\logs. Likely, there is some service or process(es) that still has the dataset locked. Run clearlocks -assert_all_dead then the generate util in a Tc command window. If that progresses well then launch TEM again.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Siemens Creator Siemens Creator
Siemens Creator

I shut off all my services, ran clearlocks -assert_all_dead as infodba and that worked. Then I ran:

generate_client_meta_cache -u=infodba -p=infodba -g=dba -t delete all

generate_metadata_cache -u=infodba -p=infodba -g=dba -force

generate_client_meta_cache -u=infodba -p=infodba -g=dba -t generate all

 

They all ran with no issues, but the client_cache_manager.log said it failed as you can see here:

=====================================================================================================================
Log File Name : C:\Temp\2\client_cache_manager.log
Option : generate Client Cache
=====================================================================================================================


---------------------------------------------------------------------------------------------------------------------
Client Cache Summary
---------------------------------------------------------------------------------------------------------------------
Step 1 of 1: Fail


---------------------------------------------------------------------------------------------------------------------
Step 1 of 1:
---------------------------------------------------------------------------------------------------------------------
Description: Process generate client cache
Executing: generate_client_meta_cache
Return code: [14112]
Result: Fail

 

 

 

I tried to run the TEM again, only to have the same issue occur. So that didn't work.

 

 

 

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Make sure you still have the FSC service running when you run TEM. All other services should be stopped.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Siemens Creator Siemens Creator
Siemens Creator

Yea I only had FSC running, all others were stopped... I can't figure out any other solution.. 

 

Is there anyway to get around this part of the install? The logs do not point in any direction on what the problem is besides a fail...

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Error 14112 usually points to a file access problem normally associated with FSC. Check the TC_ROOT\fsc\FSC_*.stdout file as it might tell you what is missing or that it can't find.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Siemens Creator Siemens Creator
Siemens Creator

I have looked into that file and did not see anything that stood out. I have attached the file below.

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Your FSC is in perfect health.

How about TCCS/TcRAC? Assuming you are logged in as infodba...
C:\Users\infodba\Siemens\logs\tccs\TCCS\process\tccs_infodba_Teamcenter_computername.log
C:\Users\infodba\Teamcenter\RAC\datetime\infodba_TcRAC_datetime.log
Change the location for whichever user you are logged into the server as.

Do you have other FSC services running on other servers or was this the only one for your Teamcenter environment?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Siemens Creator Siemens Creator
Siemens Creator

It looks like there are a lot of issues in my TCCS log as you can see in the attachment below. It is saying my tccs directory doesn't exist, but I have it in my TC_ROOT...

 

I also attached the RAC log, but it does not have any more details besides what I already knew.

 

And this is my only TC environment. It is built for testing and only has one FSC service running.

Re: Active Workspace 3.3 Install Error: generate_metadata_cache

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
The "Unable to connect to origin server url" error indicates that the FSC service is not running? But you've already confirmed that it is running and you've run the commands on the command line. This indicates a configuration problem between FCC and FSC. The FCC continues to run for 8 hours after you close Teamcenter. If you try to start up a different environment and the old FCC is still running then you can encounter an error like this. Try starting the FCC manually in a Teamcenter command window...

FMS_HOME should already be set
set JAVA_HOME="<path_to_java_version>"
cd /d %TC_ROOT%\tccs\bin
fccstat -start

Some things to check if you get a failure:
Is the FMS_HOME environment variable set to your TC_ROOT\tccs directory?
Are there other/alternate environments also installed?
In a Tc cmd, try pinging the FSC using http://<server>:4544/Ping (strangely, Ping is case sensitive)
In a Tc cmd, validate the IP address http://<server>:4544/mapClientIPtoFSCs?client=192.168.80.134
If you get an error "The webpage cannot be found" then the client IP doesn't belong to any of the FSC groups.
In a Tc cmd, get the FMS Master details http://<server>:4544/FMSMasterConfigFileRequest
Note the entry for clientmap mask and subnet
When the client IP has been included then you should get a valid response from http://<server>:4544/configAvailableFSCsRequest
Otherwise you will get a "The webpage cannot be found"

Let me know if any of this helps identify the issue.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4