Cancel
Showing results for 
Search instead for 
Did you mean: 

Deploy Data Model failed

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

While deploying the changes from BMIDE, i am getting this error.

 

Deploy Data model failed

Reson: You need to be a System Administrator to be able to run this utility.

The current user doesn't have SA priviledge.

 

How to fix this issue and let deploy the changes well ?
Attachemnt is attached for more refercence.

9 REPLIES 9

Re: Deploy Data Model failed

Gears Phenom Gears Phenom
Gears Phenom

Good afternoon, try to run BMIDE with administrator privileges

Re: Deploy Data Model failed

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Yes, i have tried the same but its not working. It seems like not even getting open also.

 

I found that it was working previously fine but don't why it is not working now.

Re: Deploy Data Model failed

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
Which operating system are you deploying to? Linux RedHat?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Deploy Data Model failed

Solution Partner Creator Solution Partner Creator
Solution Partner Creator
I am using Windows operating system.

Re: Deploy Data Model failed

Gears Phenom Gears Phenom
Gears Phenom

Good afternoon, can you post the log file after deploy error?

Re: Deploy Data Model failed

Solution Partner Creator Solution Partner Creator
Solution Partner Creator
There is no log file but only Windows pop up coming.

Re: Deploy Data Model failed

Legend
Legend

How do you connect to the TC server from BMIDE?

Which user and group?

Re: Deploy Data Model failed

Solution Partner Creator Solution Partner Creator
Solution Partner Creator
I am using DBA group.

And good thing is i got connection successful now. Actually now i can login using another user but not mine. I don't know what happened to my login ID.

And also one thing i found that role and group values are case sensitive. That's why it didn't allow me to login.

Thanks guys to help and thanks for your time.

Re: Deploy Data Model failed

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
Windows may not care about case but Java does. My next suggestion was going to be to check the database permissions. Glad you found the problem.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4