Showing results for 
Search instead for 
Did you mean: 

Dispatcher does not do multiprocess


Our dispatcher is setup with 4-cpu cores.


I've configured the dispatcher server to allow processes in parallel, by setting the properties maxlimit in translator.xml and MaximumTask in

Now up to 5 tasks can be started next to each other and run in parallel.


But when I watch the Task Manager on the dispatcher server, the processes are started but the wait after eachother.

As a result the processes are run in sequence and do not fully utilise all the cpu cores, resulting in a pore performance.



Can somebody explain this?

How can I make sure that these processes are run in parallel?


(view in My Videos)


Thanks in advance,






Re: Dispatcher does not do multiprocess

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

From the video it looks like the problem is with ugtopv.exe. Even though the dispatcher is configured to support parallel processing, the actual tool needs to support that. Contact gtac to see if ugtopv.exe support parallel running.

Re: Dispatcher does not do multiprocess


In the tcserver.syslog of the dispatcher client I’ve found the following error message:


ERROR - 2018/3/09-07:32:18.879 UTC - NoId - 26003 - The version [30] of the Metadata Cache in DB is LESS THAN the version [34] of the Metadata Cache mapped in Shared Memory; please stop Teamcenter server or process, remove the files in the TC_SHARED_MEMORY_DIR directory and restart - Teamcenter.MetaModel.sharedcache at D:\workdir\tc1016w0315_win64\src\core\sharedcache\SharedMetadataCacheMgr.cxx(232)



I’ve followed the instructions mentioned (remove the files…) and restarted the dispatcher services.


I’ve been watching the processes for a while and it seems that this solved the issue. The processes are running in parallel again:





Don’t know what caused this Shared Memory problem.


But I think my problem is solved...