Cancel
Showing results for 
Search instead for 
Did you mean: 

Getting Error in Login with Thin Client on .Net Web Tier

Siemens Creator Siemens Creator
Siemens Creator

Hi, 

 

I have following setup: 

  1. Windows Server 2008 R2
  2. MS SQL Server 2012
  3. IIS 7.5
  4. Teamcenter 11 (11.4.0.2(20180205.00)) 64-bit
  5. with WebTier for .NET (configured port is - 10080)

I could login to Rich client, however while login to Thin client with WebClient (http://pl1inpun0011v0:10080/tc/webclient) it gives some ServerAccess issue. Refer attached screen shots.

 

Also, I am unable to access admin link (http://pl1inpun0011v0:10080/tc/admin/) it gives following error: 

 

Server Error in '/tc' Application.

Unable to make the session state request to the session state server. Please ensure that the ASP.NET State service is started and that the client and server ports are the same.  If the server is on a remote machine, please ensure that it accepts remote requests by checking the value of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\aspnet_state\Parameters\AllowRemoteConnection.  If the server is on the local machine, and if the before mentioned registry value does not exist or is set to 0, then the state server connection string must use either 'localhost' or '127.0.0.1' as the server name. 

 

I am new to teamcenter so not sure where to start looking. IIS Configuration and TC installation looks okay to me. 

I thank you in advance for your suuport. 

 

Regards 

Ashish

21 REPLIES 21

Re: Getting Error in Login with Thin Client on .Net Web Tier

Gears Phenom Gears Phenom
Gears Phenom

Hello, have you tried logging in from the server itself?

Verify that the windows firewall or another does not block the connection.
Check also when you installed IIS that ASP.NET was installed

IIS.png

Re: Getting Error in Login with Thin Client on .Net Web Tier

Siemens Creator Siemens Creator
Siemens Creator

Hi, Thanks for answering. 

 

I tried login with rich client, it works. Not sure how to login from the server itself?

ASP.NET is installed. No restrictons from Firewall. As I can launch the Admin webpage and it shows server runnning too. On Webclient page login fails with error "Unable to connect to Server".

 

AdminPageLogin.PNG

 

Thanks

Ashish

Re: Getting Error in Login with Thin Client on .Net Web Tier

Gears Phenom Gears Phenom
Gears Phenom

Hello, if you try from the server go to
http://localhost:10080/tc/webclient then you get the same error?

Re: Getting Error in Login with Thin Client on .Net Web Tier

Siemens Creator Siemens Creator
Siemens Creator

Yes Arthur, the error is same "Exception in ServerAccess for user infodba: Unable to connect to the remote server"

 

Strangly it assigns the user to server but can't Authenticate it. 

 

ServerAssignment.PNG

Re: Getting Error in Login with Thin Client on .Net Web Tier

Gears Phenom Gears Phenom
Gears Phenom

In the C:\inetpub\wwwroot directory, check the web.config file for the following contents:

 

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <security>
            <authorization>
                <add accessType="Allow" users="infodba" />
            </authorization>
        </security>
    </system.webServer>
</configuration>
Highlighted

Re: Getting Error in Login with Thin Client on .Net Web Tier

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
Also, since the tcserver is getting assigned then that means we have a syslog. Can you attach it please?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Getting Error in Login with Thin Client on .Net Web Tier

Siemens Creator Siemens Creator
Siemens Creator

Attaching Syslog files. 

Re: Getting Error in Login with Thin Client on .Net Web Tier

Siemens Creator Siemens Creator
Siemens Creator

I didn't find web.config file in the metnioned foder. Refer attached screenshot. 

 

WWWRootFolder.PNG

Re: Getting Error in Login with Thin Client on .Net Web Tier

Gears Phenom Gears Phenom
Gears Phenom

Good afternoon, it looks like you have problems with tcdata or fms or shared cache.
Earlier you wrote that you can enter a rich client, try to go to Edit -> Options and find the Transient_Volume_RootDir site parameter there, which path is specified there?

Try re-generate server and client caches, as example:

1) stop Server manager process and delete Shared Memory Folder
%TEMP%\V11xxxxxx

2) Delete Client Metacache
   generate_client_meta_cache -u=infodba -p=infodba -g=dba -t delete all

3) Generate Server Metacache
   generate_metadata_cache -u=infodba -p=infodba -g=dba -force

4) Generate Client Metacache
   generate_client_meta_cache -u=infodba -p=infodba -g=dba -t generate all

5) Restarted Pool manager and try log to web client

 

6) If you can not log in, then once again post the syslog

Perhaps RandyEllsworth has something to say after it looks at your log