Cancel
Showing results for 
Search instead for 
Did you mean: 

Ghost parts importing into Teamcenter with my NX assembly!

Experimenter
Experimenter

Hello,

 

I'm trying to import a NX assembly into Teamcenter.  Everything is successful except that I get old parts that don't exist anymore follwing the assembly into Teamcenter.  I can't find these parts listed anywhere in the assembly in NX.  I can't even find the named files on my computer or network.  I've tried everything from  importing every part individually with no dependents to importing dependents only from the specified folder.  In NX I went into Utilities and Part Cleanup to try and get rid of anything attached to the assembly files but that didn't work either.  Has anybody else seen this or know of a way to look up associations within an NX assembly?  Thanks.

 

Jon

13 REPLIES

Re: Ghost parts importing into Teamcenter with my NX assembly!

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Jon_Cornell,

 

Were you able to successfully import the assembly and just looking for suggestions?

Both the ug_inspect and ug_edit_part_names utilities will likely list the "ghost" references, but they won't explain why they are being referenced.  There can be many reasons they exist, such as parts renamed on the O/S, interpart references (WAVE, promotions, positioning constraints, interpart expressions, etc), arrangements, drafting components and so on.

 

Regards, Ben

Re: Ghost parts importing into Teamcenter with my NX assembly!

Experimenter
Experimenter

I need to be able to delete these extra parts or prevent them from following the assembly to be imported.  They seem to be old parts that I either renamed or replaced.  I cloned the assembly prior to importing into Teamcenter to create consistant names.  The extra parts aren't part of the original assembly as far as I can tell though.  Thanks.

 

Jon

Re: Ghost parts importing into Teamcenter with my NX assembly!

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Jon_Cornell,

You didn't mention whether or not the assembly successfully imports.

If you don't know how or why these ghost parts are being referenced it's unlikely that you'll be able to delete them, or prevent them from being referenced in the assembly.  Are they only reported when the assembly is being imported or is a similar message raised on File > Open?

If part files have been renamed on the OS, the ghost references typically get called after the new names, which sometimes helps identify which parts were renamed and where to redirect references using the ug_edit_part_names utility.  

Which version of NX and Teamcenter are you using?

You might want to consider contacting your local GTAC office to have them review your assembly and help identify why these parts are being referenced.  They can help you clean up the parts.

Regards, Ben

Re: Ghost parts importing into Teamcenter with my NX assembly!

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Don't forget to grab/review the .clone file. It can help you figure out what's being imported before actually importing the assembly (Dry Run).

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Ghost parts importing into Teamcenter with my NX assembly!

Valued Contributor
Valued Contributor

I am having exact same problem. Not sure how to get rid of those Name Only - Referenced parts, which are not actual components of the assembly that I am trying to import.

I did exactly what Jon did. Cloned the assembly locally to correct part names/numbers first. And then, trying to import it into Teamcenter.

Thanks,
Anbu

Teamcenter Architect & PLM/CAD Administrator,
Teamcenter 11.4 | Active Workspace 3.4 | NX 12
Highlighted

Re: Ghost parts importing into Teamcenter with my NX assembly!

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
@AnbuPLM, I've reached the limit of personal messages that can be sent so am answering you on this forum...

According to the docs, in the Configuration panel (icon looks like a bom with a wrench), check the "Pack Similar Elements" checkbox. To unpack, uncheck the box. The initial value of the checkbox is controlled by the PSEAutoPackPref preference (set to 1 for packing). The gotcha: you cannot pack indexed structures so the "Use index from date" box must be unchecked. If the index box is checked then the packing box is not displayed. Intuitive right?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Ghost parts importing into Teamcenter with my NX assembly!

Valued Contributor
Valued Contributor

Thanks, I will also refer documents on Configuration panel again.

But, as-is, I do not see any Index or Pack related check boxes in Configuration Panel.

PFA the screenshot image.

Thanks,
Anbu

Teamcenter Architect & PLM/CAD Administrator,
Teamcenter 11.4 | Active Workspace 3.4 | NX 12

Re: Ghost parts importing into Teamcenter with my NX assembly!

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
Here's the link...
https://docs.plm.automation.siemens.com/tdoc/aw/3.4/aw_html_collection/#uid:xid1337770:index_xid1337...

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Ghost parts importing into Teamcenter with my NX assembly!

Valued Contributor
Valued Contributor

A catch Smiley Happy Its available in AWC 3.4 but not in 3.3

Thanks,
Anbu

Teamcenter Architect & PLM/CAD Administrator,
Teamcenter 11.4 | Active Workspace 3.4 | NX 12