Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Import assembly into teamcenter

Builder
Builder
Dear all,

I want to import two different assemblies into Teamcenter using “Import Assembly into Teamcenter” command. These assemblies have some common parts.

Importing the first Assembly is done successfully. But when I want to import the second one, I have problem with common parts that exist in Teamcenter previously.

I use these Options:



Item Type: Item

Numbering Source: OS Filename

Conversion Rule: As ID and Revision

Default Name: ${NAME}

Default Description: ${DB_PART_DESC}

Existing Part Action: New Revision



In Teamcenter Information column I get this massage: The specified item already exists in Teamcenter. A new revision will be created for this part.

and after a Dry Run I get this Error: Item id is invalid.

Even if I set the “Existing Part Action” to “Use Existing”, I receive the same Error.





I use Teamcenter 11.3 and NX 11.0.0.33
Sina Shojaee
2 REPLIES 2

Betreff: Import assembly into teamcenter

Solution Partner Legend Solution Partner Legend
Solution Partner Legend

Does your naming rules disallow to use the OS Filename as numbering source?

Michael
Teamcenter UA | NX CAD

Re: Import assembly into teamcenter

Siemens Esteemed Contributor Siemens Esteemed Contributor
Siemens Esteemed Contributor

@Sina wrote:

I use Teamcenter 11.3 and NX 11.0.0.33

Hi @Sina,

 

I suspect your problem is related to your version of NX - you're using the base release of NX 11, which has since had 2 maintenance releases posted.  Your problem appears to be very similar to what was reported in PR 7857668 (NX Import Assembly into Teamcenter cannot overwrite existing item ID) which was fixed in NX 11.0.1.

 

Please upgrade NX to at least NX 11.0.1 and repeat your steps.

 

Regards, Ben