Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Legend
Legend

no, it's a different databases. But this srcipt mostly use ug_clone utility from nx installation

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Correct.  The scripts that we provide to import the templates into Teamcenter use ug_clone.  In order for the templates to be imported they have to conform to whatever has been defined using BMIDE and/or Teamcenter.  Since this works for one database and not another we need to establish what is different between the two - hence asking if they are using the same BMIDE templates.  Name rules are defined using BMIDE and since this *appears* to be a name rule issue that was the reason for my question.  Do you even have name rules defined?

 

Please answer this previous question:
Are you able to import one of the template part files manually (from NX using Import Assembly into Teamcenter) into the Teamcenter database using the same user/group that is importing the templates?

 

Regards, Ben

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Legend
Legend

@BenBroad wrote:

 

Please answer this previous question:
Are you able to import one of the template part files manually (from NX using Import Assembly into Teamcenter) into the Teamcenter database using the same user/group that is importing the templates?

 

Regards, Ben


No. Also I cant see MENCMachining item type in NX File->New Dialog. Also when I run Import Assembly from NX - I also cant see MENCMachining item type in the type list.

 

I tried another way - go to Teamcenter CAM templates folder with old version of cam templates, make Save As MENCMachining item and give them new ID with _NX10_Update suffix and then import via named references template file from NX installation.

 

After that I edited nxdm_manufacturing_templates.pax file for test, ItemType tag value is setting to MENCMachining, but in NX syslog I still see "Skipped unsupported item type MENCMachining during processing pax file".

If I set ItemType to "Item" then template will be processed and applied.

 

TC admins of this DB assure me that in BMIDE MENCMachining BO not hidden and all by default. But it's seems like the MENCMachining type somehow hidden, cause I dont see it in Teamcenter File-New or NX File-New dialog

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
In Teamcenter, what values do you have for NX_supported_operation_types? Do you have a custom MENCMachining item type or ootb?

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Also, check to see what is defined for the Teamcenter property: Tc_part_types_display_filter.

I've seen this when there has been a group based display rule set in BMIDE.

 

Regards, Ben

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Legend
Legend

@BenBroad wrote:

Also, check to see what is defined for the Teamcenter property: Tc_part_types_display_filter.

I've seen this when there has been a group based display rule set in BMIDE.

 

Regards, Ben


Thanks! Tc_part_types_display_filter - this setting I didn't check.

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Legend
Legend

@RandyEllsworth wrote:
In Teamcenter, what values do you have for NX_supported_operation_types? Do you have a custom MENCMachining item type or ootb?

The value is MENCMachining and there is no any custom type. All as default. I dont think the reason in this preference

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Legend
Legend

thanks a lot Ben!

I locate Tc_part_display_filter preference, yes - the filter was active, I added MENCMachining value and after that I was able to see and create MENCMachining type from NX, and finally - the tcin_cam_setup_templates utility  now works successfull after editing this preference!

 

It's magic! )

 

Well, problem was solved. Thanks all

Re: Problem: importing templates 'tcin_template_setup.bat' has error

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor
Good to know it helped you solve the problem. Please mark the thread solved.

Regards, Ben