Cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with Teamcenter NX Integration

Creator
Creator

Hello,

I´ve got a problem with the Teamcenter NX Integration.

I´am using Teamcenter 11.3 (4-Tier) and NX 11. I installed the NX Rich Client Integration about TEM.

The Path to NX is Right. The entries in the Windows Registration are correct. NXmanager_portal.bat & Start_NXmanager.bat are at the correct place. (Tcroot/Portal)

There are no Issue´s at the Start from NX.

When i use "ugraf -pim=yes -u="user" -p="password", NX connect correct to Teamcenter.

But when i try to load something from Teamcenter into NX. There is always the Router Error:

"Cannot connect to or start the Application UG/Manager V29.0"

With the command

%UGII_BASE_DIR%\UGII\ugs_router -ugm  

 The Router Error says: Failed to start the other Application.

Please give me some hint , what maybe could wrong?

From my point of View everthing looks good, i dont know what wrong.

8 REPLIES

Re: Problems with Teamcenter NX Integration

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Fl33xx

 

If you log into this client workstation as a different Windows user are you able to Send to NX from Teamcenter?

 

Regards, Ben

Re: Problems with Teamcenter NX Integration

Creator
Creator

Hi Ben,

Same Error, when i try to start it as a different User.

Re: Problems with Teamcenter NX Integration

Creator
Creator

Found the Error. A entry in the Windows Registry was wrong...

Re: Problems with Teamcenter NX Integration

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @Fl33xx,

 

A entry in the Windows Registry was wrong...

 

Can you explain further in case it helps someone else at a later date experiencing the same problem?

 

Regards, Ben

Re: Problems with Teamcenter NX Integration

Experimenter
Experimenter
Hello FI33XX,

Could you please explain what may be wrong in windows registry key? because I am also facing the same issue for the group of people.
Your quick response would be appreciated...
Thanks in advance...
Regards,
Venu Thallada.

Re: Problems with Teamcenter NX Integration

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
You don't state your exact issue but maybe the solution on this thread will help...
https://community.plm.automation.siemens.com/t5/Teamcenter-Administrators-Forum/ERROR-Failed-to-star...

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Problems with Teamcenter NX Integration

Experimenter
Experimenter

Hello Randy,

 

my problem is 

There is always the Router Error:

"Cannot connect to or start the Application UG/Manager V29.0".

 

but finally, I found the issue where exactly it is causing. which wrong windows registry entry. So I modified registry entry and now all set to launch NX from Teamcenter

 

Thank you for your quick response. will be in touch... Have a great weekend and have fun!

 

regards

Venu Thallada.

Re: Problems with Teamcenter NX Integration

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @venuthallada,

 

Please let us know which registry entry you modified in the event that it helps someone who encounters this problem in the future.

 

Regards, Ben