Cancel
Showing results for 
Search instead for 
Did you mean: 

TC-NX: 'Model' tab location

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello,

 

I have NX 9 (9.0.3.4) installed on my system already and just installed Teamcenter 10.1.0 for the TC-NX integration testing. I am seeing one odd behaviour for the model application tab order in 'New' dialog box of NX.

 

In native NX, the 'Model' tab appears at first. tab native nx.PNGNative NX 9

However in managed NX, the 'Model' tab appears at the end as shown. 

tab manged nx.PNGManaged NXAfter TC installation there were no changes made to NX or TC side. Wondering about this strange behaviour. Do I need to set/change something by TC side for NX?

6 REPLIES

Re: TC-NX: 'Model' tab location

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Hi @GaneshKadole,

 

The only time I've witnessed this was when the filenames of the 'nxdm' pax files were renamed.

Are you managing your pax files in Teamcenter?
Are you using NXCustom?
Have you set UGII_TEMPLATE_DIR or edited custom_dirs.dat to point to a directory other than %UGII_BASE_DIR%\ugii\templates\?

What region/language do you have set in Windows?

 

Regards, Ben

Re: TC-NX: 'Model' tab location

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi @BenBroad,

Initially I had created items/parts from and NX and saved it. When item is created in TC without UGMASTER dataset and tried to open in NX, it is showing the error for seed parts in the database.seed.png

 Can this be a reason for the 'Model' tab location behaviour?

Re: TC-NX: 'Model' tab location

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

Look in infodba's Unigraphics Seed Parts folder - do you have any files there?  If they're missing then they were either deleted, moved from that folder, or you haven't installed the NX integration completely.

If NX was unable to find any template part files in the database you would only see "blank" templates on the tabs. 

Re: TC-NX: 'Model' tab location

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom
@BenBroad, it's likely that they're not using the ootb Item type and have their own Item type that needs to be added to the nxdm*.pax files. Not an easy thing to explain though.

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: TC-NX: 'Model' tab location

Siemens Honored Contributor Siemens Honored Contributor
Siemens Honored Contributor

@RandyEllsworth - except for this:

 

After TC installation there were no changes made to NX or TC side

No mention of BMIDE tho Smiley Wink

Since the templates are loading (visible on the File New dialog with the model tab selected) the NX session is reading the Item Type associated with the pax file.

 

@GaneshKadole - have you tried hitting the dialog reset icon?

Re: TC-NX: 'Model' tab location

Siemens Phenom Siemens Phenom
Siemens Phenom

@BenBroad wrote:

Look in infodba's Unigraphics Seed Parts folder - do you have any files there?  If they're missing then they were either deleted, moved from that folder, or you haven't installed the NX integration completely.

If NX was unable to find any template part files in the database you would only see "blank" templates on the tabs. 


Hi @BenBroad,

As you have mentioned about 'Unigraphics seed parts' folder, may be this was the issue. Unfortunately, I had to remove the TC10 setup and was not able to fix/verify this issue. I have now TC11 integrated with NX11. Now there are seed parts present with appropriate 'nxdm' files. Now I can see 'Model' tab at correct location.

 @RandyEllsworth, also your reply about 'nxdm' PAX files had helped me to know that what should I look for.

 Thank you to both of you! Smiley Happy