Cancel
Showing results for 
Search instead for 
Did you mean: 

Teamcenter 10.1 and Jboss Configuration issues.

Creator
Creator

Dear all,

 

I have installed Teamcenter 10.1 Corporate server on system and i want to access this Enterprise Tier from another system with TC 4T. For this, we need Java EE web tier installation which also i have installed. But when i paste my .EAR file in \Jboss\jboss-as-7.1.0.Final\standalone\deployments and Run Standalone.bat from \Desktop\Jboss\jboss-as-7.1.0.Final\bin  deployment is failing. Please suggest step wise instalaltion of same.

 

 

Below is error on Jboss console: 

 

{"JBAS014653: Composite operation failed and was rolled back. Steps that failed:" => {"Operation step-2" => {"JBAS014671: Failed services" => {"jboss.ra.deployer.\"TBMROOT.ear#JETIAdapter\"" => "org.jboss.msc.service.StartException in service jboss.ra.deployer.\"TBMROOT.ear#JETIAdapter\": JBAS010446: Failed to start RA deployment [TBMROOT.ear#JETIAdapter]"},"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.naming.context.java.module.TBMROOT.TBMROOT.env.ejb.Gatewayjboss.naming.context.java.global.tc.JETIGateway-ejb.\"Gateway!com.teamcenter.jeti.ejb.GatewayHome\"Missing[jboss.naming.context.java.module.TBMROOT.TBMROOT.env.ejb.Gatewayjboss.naming.context.java.global.tc.JETIGateway-ejb.\"Gateway!com.teamcenter.jeti.ejb.GatewayHome\"]","jboss.naming.context.java.comp.TBMROOT.JETIGateway-ejb.Gateway.env.jca.JETI.Adapterjboss.naming.context.java.jboss.resources.jca.JETI.AdapterMissing[jboss.naming.context.java.comp.TBMROOT.JETIGateway-ejb.Gateway.env.jca.JETI.Adapterjboss.naming.context.java.jboss.resources.jca.JETI.Adapter]"]}}}

8 REPLIES
Highlighted

Re: Teamcenter 10.1 and Jboss Configuration issues.

Are you adding -b 0.0.0.0 to the launch command?

Re: Teamcenter 10.1 and Jboss Configuration issues.

Legend
Legend

What JRE/JDK version needed for installation JBoss8(WildFly)? JDK 1.7.25 as I see not supported

Re: Teamcenter 10.1 and Jboss Configuration issues.

When on 10.1, I would stick to jboss-as-7.1.0.Final and JAVA 7.

Re: Teamcenter 10.1 and Jboss Configuration issues.

Legend
Legend

@Ramon_Talavera wrote:

When on 10.1, I would stick to jboss-as-7.1.0.Final and JAVA 7.



For TC 10 JDK 1.7.25 is minimum recommended version. I suppose some update for 1.7 needed or 1.8.

 

 

Re: Teamcenter 10.1 and Jboss Configuration issues.

Legend
Legend

@Ramon_Talavera wrote:

Are you adding -b 0.0.0.0 to the launch command?


Where I can found this setting in Jboss(WildFly) 7.1.0 ? Or other settings and config files are using in last version of JBoss?

Re: Teamcenter 10.1 and Jboss Configuration issues.

As far as I remember, JBoss AS 7 / TC10.1 were not working fine under JAVA 8. I recommend you to check Siemens guide to setup the application server properly. Once done, use -b 0.0.0.0 to launch JBoss. 

Re: Teamcenter 10.1 and Jboss Configuration issues.

Legend
Legend

@Ramon_Talavera wrote:

As far as I remember, JBoss AS 7 / TC10.1 were not working fine under JAVA 8. I recommend you to check Siemens guide to setup the application server properly. Once done, use -b 0.0.0.0 to launch JBoss. 


I installed jboss 7.1.1 instead of 7.1.0,used JDK 1.7 instead of 1.8(tc10 also use jdk 1.7), make some tuning from corresponding PDF from GTAC (jboss 7.1.0 tuning guide) and thin client now works fine.

Re: Teamcenter 10.1 and Jboss Configuration issues.

That's good news.