Cancel
Showing results for 
Search instead for 
Did you mean: 

Template deployment failed at particular stage

Builder
Builder

As part of update,while deploying template into TC DB using tem.bat (selecting Full Update-System Downtime required)
it returns an error as::

installation interrupted due the following reason:

Processing <maintenance> of feature Teamcenter Foundation failed: com.teamcenter.install.tceng.struct.exceptions.ced.EngineeringUtilityException:
One of the Teamcenter utilities has failed.
Time: Fri May 27 16:28:51 IST 2016


Kindly check the stage 4 of 6.
---------------------------------------------
Detailed Log is below::
---------------------------------------------
*
** Running command 1 of 6
**
Executing 'install -lock_db infodba ***** dba >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"'...
Output from command: install -lock_db infodba ***** dba >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"
command_exit=0
Exit Status 0, elapsed time 0:00:01
**
** Running command 2 of 6
**
Executing 'clearlocks -assert_all_dead infodba ***** dba >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"'...
Output from command: clearlocks -assert_all_dead infodba ***** dba >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"
command_exit=0
Exit Status 0, elapsed time 0:00:00
**
** Running command 3 of 6
**
Executing 'install -regen_schema_file infodba ***** dba >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"'...
Output from command: install -regen_schema_file infodba ***** dba >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"
command_exit=0
Exit Status 0, elapsed time 0:00:02
**
** Running command 4 of 6
**
Executing 'business_model_updater -u=infodba -p=***** -g=dba -file=E:\TESTPR~1\TCDATA/model/delta.xml -update=all -mode=upgrade >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"'...
Output from command: business_model_updater -u=infodba -p=***** -g=dba -file=E:\TESTPR~1\TCDATA/model/delta.xml -update=all -mode=upgrade >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"
command_exit=226007
Exit Status 226007, elapsed time 0:00:33
Utility failed. Make a second attempt.
Executing 'business_model_updater -u=infodba -p=***** -g=dba -file=E:\TESTPR~1\TCDATA/model/delta.xml -update=all -mode=upgrade >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"'...
Output from command: business_model_updater -u=infodba -p=***** -g=dba -file=E:\TESTPR~1\TCDATA/model/delta.xml -update=all -mode=upgrade >>"E:\TESTPR~1\TEAMCE~1\logs\tc_install.log"
command_exit=226007
Exit Status 226007, elapsed time 0:00:08
Executing 'E:\TESTPR~1\TEAMCE~1\bin\bmide_manage_templates.exe -u=infodba -p=***** -g=dba -option=fullupdate -templates=tdpsph1'...
Output from command: E:\TESTPR~1\TEAMCE~1\bin\bmide_manage_templates.exe -u=infodba -p=***** -g=dba -option=fullupdate -templates=tdpsph1
Registering libtdps...1.0.0.12
Full Update completed successfully
command_exit=0
Exit Status 0, elapsed time 0:00:06
An error occurred during execution. Stack trace follows...
com.teamcenter.install.tem.tasks.JavaTask.execute(JavaTask.java:131)
com.teamcenter.install.tem.tasks.Task.execute(Task.java:106)
com.teamcenter.install.tem.tasks.blocks.CodeBlock.execute(CodeBlock.java:140)
com.teamcenter.install.tem.struct.TcFeature.processAction(TcFeature.java:1098)
com.teamcenter.install.tem.struct.TcFeature.process(TcFeature.java:1043)
com.teamcenter.install.tem.struct.TcFeature.maintenance(TcFeature.java:825)
com.teamcenter.install.tem.director.actions.MaintenanceAction.execute(MaintenanceAction.java:30)
com.teamcenter.install.tem.director.DirectorScript.execute(DirectorScript.java:111)
com.teamcenter.install.tem.director.Director.run(Director.java:53)
java.lang.Thread.run(Thread.java:619)
***
*** CANCELLED
***
=====================================================
Installation interrupted due the following reason:

Processing <maintenance> of feature Teamcenter Foundation failed: com.teamcenter.install.tceng.struct.exceptions.ced.EngineeringUtilityException: One of the Teamcenter utilities has failed.
Time: Fri May 27 16:28:51 IST 2016
=====================================================
Copying file E:\TESTPRODDB\Teamcenter832\install\configuration.xml to E:\TESTPRODDB\Teamcenter832\install\configuration1605271628.xml

5 REPLIES

Re: Template deployment failed at particular stage

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hi,

 

Could you please share the error messages from the syslog?

 

 

Did you find any un-processed schema elements?

 

Best Regards

Harish

Re: Template deployment failed at particular stage

Builder
Builder

Hello Harish,

 

Thanks.I have checked syslog files, whatever i made a changes on template (added one field to form) ,it is showing in that form in the TC.Once deployment failed, we couldn't see any changes. But, it is appearing.How?

Re: Template deployment failed at particular stage

Valued Contributor
Valued Contributor
Have you been able to resolve this issue?

I just had this happen to me on a full deployment.

Thanks
Jake

Re: Template deployment failed at particular stage

Valued Contributor
Valued Contributor

If possible, can you please share how you were able to resolve this issue?

 

Thanks

@SwamyRangu

Jake

Re: Template deployment failed at particular stage

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

Hello,

 

I came across the same error and found that there were unprocessed non-schema elements during deployment.

In my case, a type display rule was set on a particular group for a workspace object in BMIDE and then the group was removed from the Teamcenter organization tree. This caused the failure.

 

Additionally, when I got the error during TEM deployment, I tried a hot deployment which worked and followed by a TEM recovery mode which was successful too. However, a new cold deployment after these steps still failed untill I figured out what the problem was that I mentioned above.

 

Hope this helps!

 

Thanks!

 

Regards,

Tony!