Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Unable to find ItemName

Builder
Builder

Hi @PaoloC 

i checked the Oracle DB password is not expired.

DB is open and up also listeners are running.

is their any other issues which is throwing error message as "POM has not started"

through cmd am unable to regen_schema_file.

am getting message as "Caught an error while installing ... aborting!"

 

Regards

sameer kulkarni

 

Re: Unable to find ItemName

Siemens Legend Siemens Legend
Siemens Legend

Then I think you have something wrong in the TC configuration that doesn't allow the connection to the db.

Please, double check your TC_DATA (mainly tc_profilevars.bat/.sh and tnsnames.ora)

 

Paolo

Highlighted

Re: Unable to find ItemName

Solution Partner Esteemed Contributor Solution Partner Esteemed Contributor
Solution Partner Esteemed Contributor
@sam11

Even though the Oracle password hasn't expired yet, you will get a popup warning that your password will soon expire, which causes Tc processes to fail because they cannot handle the popup.

You can try this...
Start command shell:
set ORACLE_HOME=<your home>
set ORACLE_SID=tc
sqlplus

Enter user/pass (infodba might work…. or you may need to use the SYSTEM login)

select expiry_date from dba_users where username='INFODBA';
select profile from dba_users where username='INFODBA';

# change the password for user infodba to infodba.
alter user infodba identified by infodba;

# prevent this from happening again in 6 months.
alter profile default limit PASSWORD_LIFE_TIME unlimited;
alter profile default limit PASSWORD_GRACE_TIME unlimited;
alter profile default limit PASSWORD_LOCK_TIME unlimited;
alter profile default limit FAILED_LOGIN_ATTEMPTS unlimited;

This allowed the user to login

Randy Ellsworth, Teamcenter Architect, Applied CAx, LLC
NX 11 | SW 2016 | Creo 4 | TcUA 11.4
Evaluating: AW 3.4

Re: Unable to find ItemName

Builder
Builder

Hi @RandyEllsworth 

 

we have corrected the Oracle DB password as per your instructions.

also i generated a new connection string using install -encrypt option

and replaced the same in TC_DB_CONNECT and IMAN_DB_CONNECT, in tc_profilevars.bat file

but still am unable to connect DB.

if i execute install.exe -ayt through cmd am getting (check_db) failed to connect message

this issue am getting after maintenance activity our server got rebooted.

before that its working fine i was doing volume connection.

 

Regards

sameer kulkarni

Re: Unable to find ItemName

Builder
Builder

Hi @RandyEllsworth 

i have corrected all possible oracle errors but still am getting below information in tcserver.syslog

could you please help me out to get error resolved. 

am able to connect DB through tnsping between Application server and DB server. 

,also i can connect through sql , even listeners are working fine.

but still unable to connect DB through Teamcenter.

 

ERROR - 2019/06/19-09:22:32.550 UTC - NoId - 26052 - ITK_init_module_prelogin with error 354896681 - Teamcenter.CoreModelGeneral.tc at d:\workdir\tc12w0710_64\src\core\tc\infomanager_itk.cxx(2131)
INFO - 2019/06/19-09:22:32.679 UTC - NoId - xercesc_3_2 has been initialized. - Teamcenter.SOA.Server
INFO - 2019/06/19-09:22:32.680 UTC - NoId - ServerID: TcServer1 - Teamcenter.Soa.Communication
INFO - 2019/06/19-09:22:32.680 UTC - usmtnasdengap02.07904 - Using code page UTF-8 for local encoding of service request/response - Teamcenter.SOA.Server
INFO - 2019/06/19-09:22:32.681 UTC - usmtnasdengap02.07904 - INIT:: confused by module POM in state 3 - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\init\init.cxx(273)
INFO - 2019/06/19-09:22:33.065 UTC - usmtnasdengap02.07904 - INIT:: confused by module POM in state 3 - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\init\init.cxx(273)
Session is running in codeset 1252 17
INFO - 2019/06/19-09:22:33.065 UTC - usmtnasdengap02.07904 - Default encryption configuration. - Teamcenter.FoundationBase at d:/workdir/tc12w0710_64/src/foundation/base/KeyManagerTcCrypto.cxx(138)
WARN - 2019/06/19-09:22:33.065 UTC - usmtnasdengap02.07904 - TC_USE_KEYMANAGER environment variable is configured to not use KeyManager. - Teamcenter.FoundationBase at d:/workdir/tc12w0710_64/src/foundation/base/KeyManagerTcCrypto.cxx(199)
Oracle env: NLS_LANG=american_america.al32utf8.
Oracle env: NLS_SORT=BINARY.
WARN - 2019/06/19-09:22:33.069 UTC - usmtnasdengap02.07904 - -12154 - Connect failed (-12154) for 'infodba' at DATABASE=CERTDWGT;server=usmtnasdengap01.emrsn.org - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_trans_util.cxx(989)
Oracle env: NLS_LANG=american_america.al32utf8.
Oracle env: NLS_SORT=BINARY.
WARN - 2019/06/19-09:22:33.072 UTC - usmtnasdengap02.07904 - -12154 - Connect failed (-12154) for 'infodba' at DATABASE=CERTDWGT;server=usmtnasdengap01.emrsn.org - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_trans_util.cxx(989)
Oracle env: NLS_LANG=american_america.al32utf8.
Oracle env: NLS_SORT=BINARY.
WARN - 2019/06/19-09:22:33.075 UTC - usmtnasdengap02.07904 - -12154 - Connect failed (-12154) for 'infodba' at DATABASE=CERTDWGT;server=usmtnasdengap01.emrsn.org - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_trans_util.cxx(989)
Oracle env: NLS_LANG=american_america.al32utf8.
Oracle env: NLS_SORT=BINARY.
WARN - 2019/06/19-09:22:33.078 UTC - usmtnasdengap02.07904 - -12154 - Connect failed (-12154) for 'infodba' at DATABASE=CERTDWGT;server=usmtnasdengap01.emrsn.org - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_trans_util.cxx(989)
Oracle env: NLS_LANG=american_america.al32utf8.
Oracle env: NLS_SORT=BINARY.
WARN - 2019/06/19-09:22:33.080 UTC - usmtnasdengap02.07904 - -12154 - Connect failed (-12154) for 'infodba' at DATABASE=CERTDWGT;server=usmtnasdengap01.emrsn.org - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_trans_util.cxx(989)
Oracle env: NLS_LANG=american_america.al32utf8.
Oracle env: NLS_SORT=BINARY.
WARN - 2019/06/19-09:22:33.083 UTC - usmtnasdengap02.07904 - -12154 - Connect failed (-12154) for 'infodba' at DATABASE=CERTDWGT;server=usmtnasdengap01.emrsn.org - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\eim\eim_trans_util.cxx(989)
INFO - 2019/06/19-09:22:33.083 UTC - usmtnasdengap02.07904 - VRF: detected startup problem. - Teamcenter.POM at d:\workdir\tc12w0710_64\src\foundation\pom\vrf\vrf_messages.cxx(61)

________________________________________________________________________________

Teamcenter could not connect to the DBMS specified in the
TC_DB_CONNECT environment variable.
This could be because the DBMS is not online or the server
is not accessible from your node.