Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

me_create_mbom Utility not Working Properly for Reused Subassemblies (OOTB Func)

Siemens Creator Siemens Creator
Siemens Creator

me_create_mbom Utility, ME_create_mbom_from_ebom API, ME-create-mirror-mbom-AH  not Working Properly for Reused Subassemblies

The new MBOM is created but NO IDIC are generated for the Child Lines for the Reused Subassembly which already has a Part Representation.

When we run the Advanced Accountaility Check ( it  will result with 2 Missing components Missing in the MBOM and 2 Missing components in the Source BOM )

 

TC Version 11.4.03

 

Steps to Duplicate:
========================================

  1. Create a structure with 2 Sub-Assemblies and 2 Components in each Sub Assemblies.
  2. Set the Alignment Type for the Subassemblies as Light and all components as Heavy
  3. Create the MBOM Using Utility me_create_mbom, works Fine - No Difference in Advanced Accountablity Check (Perfect EBOM-MBOM)1_EBOM_Create.jpg
  4. Create another Parent Line and use the Sub-Assy1, and set the Alignment type.
  5. Create MBOM for the New Parent line Using the Utility me_create_mbom.
  6. Create another Parent Line and use the Sub-Assy1, and set the Alignment type.
    2_EBOM_Reuse.jpg
  7. Create MBOM for the New Parent line Using the Utility me_create_mbom.

    3_AAC_Results.jpg

 

 

The new MBOM is created but NO IDIC are generated for the Child Lines for the Reused Subassembly which already has a Part Representation.

 

When we run the Advanced Accountaility Check ( it  will result with 2 Missing components Missing in the MBOM and 2 Missing components in the Source BOM )