Cancel
Showing results for 
Search instead for 
Did you mean: 

C1.Win.C1FlexGrid.2.dll not compatible with lower version of PS (lower then PS13.1.2)

Pioneer
Pioneer

Hello,

 

I found a problem with version compatibility between PS13.1.2 and lower versions.

In PS13.1.2 dll C1.Win.C1FlexGrid.2 has version 2.0.20162.188.

For example in PS13.0 C1.Win.C1FlexGrid.2 has version 2.6.20112.624.

 

As a result when you create command which use TxFlexGrid in version PS13.1.2 and will try to use it on PS13.0 it will not work on Disconnected PS (what is intresting, it works on eMServer version).

 

Do you plan to solve this issue in uppper (then PS13.1.2) version of PS?

 

BR,

Terror_Error

4 REPLIES

Re: C1.Win.C1FlexGrid.2.dll not compatible with lower version of PS (lower then PS13.1.2)

Phenom
Phenom

Hello @Terror_Error

 

I still haven't changed PS version for dotNet developments that I've done since I started developing APIs, but when changing PS version don't you need to rebuild your project with all new dll references?

 

What I mean is that when you change those references from Tecnomatix assemblies, maybe it is also a good practice to change the C1 assembly too (using the dll inside eMPower folder), so you will always be synchronized with the active version you're working.

 

Otherwise, as you mention in your comment, you can experience bad behaviors.

 

Regards,

 

 

Re: C1.Win.C1FlexGrid.2.dll not compatible with lower version of PS (lower then PS13.1.2)

Pioneer
Pioneer

Hi,

 

The problem is not trivial.

When I add new .dll (C1.Win.C1FlexGrid v2.0.50727) to old version of PS(13.1.0) and I create instance of TxFlexGrid. I got message as in attachment.

For now I do not see any other oportunity then making to separate compilation on for PS13.1.0 second for PS(13.1.2).

It makes all process laborious.

BR,

Terror_error,

Re: C1.Win.C1FlexGrid.2.dll not compatible with lower version of PS (lower then PS13.1.2)

Siemens Phenom Siemens Phenom
Siemens Phenom

You should compile your dll with the Tecnomatix version you are working with. If you want to use the dll in 13.0, compile it with 13.0.

I´m not sure the API is downward compatible.

Some new stuff was added between 13.0 and 13.1.2. 

 

Best regards

Patrick

Re: C1.Win.C1FlexGrid.2.dll not compatible with lower version of PS (lower then PS13.1.2)

Siemens Genius Siemens Genius
Siemens Genius

Hi

We were not aware of such an issue. I will open a PR in our system to figure out the root cause for the problem.