Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Debugging: Breakpoint will not be hit

Siemens Legend Siemens Legend
Siemens Legend

Try putting the full path also in the Start External Program entry.

I.e., browse to Tune.exe, using the "..." button next to the Start External Program field, and let VS populate the entry as it sees fit (I tried, it wants to set the full path).

Re: Debugging: Breakpoint will not be hit

Creator
Creator

When I put the full path of the Tune.exe PS starts, but debugging is still not working.

 

Do you think the problem occurs because I'm starting VS as another user?
Maybe it also depends on the Dump File Creation Settings in the TecnomatixDoctor.

Also I tried to solve this problem by reinstalling VS, but it didn't help.

Re: Debugging: Breakpoint will not be hit

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi,

 

I´m using the following settings in VS2015:

debug.png

 

"W:\" is substituded via cmd and points directly to the eMPower folder in my installation.

My installation is e.g. "D:\apps\Tecnomatix_14.1\eMPower"

 

I´m using WIN10 and in this case I have to run the subst command as administrator and VS as admin as well.

 

This works perfect for me.

I´m not sure PS13.1 is compatible with VS2017.

Maybe Zachi can confirm this is possible.

 

Best regards

Patrick

Re: Debugging: Breakpoint will not be hit

Creator
Creator

I tried it with VS2015, but it doesn't work either.

I don't understand why the Modules Window is empty when I start debugging.

When I stop debugging PS is still open so I can attach to it again. This way the modules are loaded.

But why not in the first place???

 

Does anyone has an idea?

Or any other suggestions what I can try?

 

Every hint is very welcome!

Re: Debugging: Breakpoint will not be hit

Creator
Creator

What's the content of your Tune.exe.config file inside the eMPower-Folder?

That of mine is:

 

<?xml version ="1.0"?>
<configuration>
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v4.0"/>
  </startup>
  <runtime>
      <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
         <probing privatePath="EAWS"/>
      </assemblyBinding>
   </runtime>
</configuration>

Re: Debugging: Breakpoint will not be hit

Siemens Legend Siemens Legend
Siemens Legend

Hi,

try to subst the location of tune.exe to some drive (like in Petrick's screenshot). Don't forget to restart VS after you subst.

 

Highlighted

Re: Debugging: Breakpoint will not be hit

Creator
Creator
Hi,
I tried it, but unfortunately it didn't solve my problem.

Re: Debugging: Breakpoint will not be hit

Siemens Legend Siemens Legend
Siemens Legend

I'll summarize what I found so far:

I was able to reproduce the same issue with VS2017.

It doesn't happen with VS2015 or older VS versions.

 

* When starting tune.exe then attach from VS - module debug information is loaded and breakpoints can be set.

* When starting debugging from VS using "Start External Program" option, module debug info is not loaded at all.

* Using mapped drive makes no difference.

* Disabling dump file creation for PS ebables VS to attach to tune.exe - but it is not related to this problem.

 

Current workaround is to start tune.exe from shortcut/command line, and then attach from VS.

I'm still searching for a better solution / workaround.

 

 

Re: Debugging: Breakpoint will not be hit

Creator
Creator

I finally solved the problem.

What I did:

 

1) Uninstalled everything what is VS related with the Software VisualStudioUnistaller (https://github.com/Microsoft/VisualStudioUninstaller)

 

2) Used my old offline installer to install VS2017 Community (Version 15.7.2)

 

3) In Tecnomatix Doctor first checked the Options "Enable dump file creation" and "Enable diagnostic tool" and then unchecked them again.

 

Thank you all for your help!

Re: Debugging: Breakpoint will not be hit

Pioneer
Pioneer

Hi at all,

 

i had the same problem for 2 day. And no one could help.

Lastly i read this thread again and i found the problem.

 

2 Days ago i had an IR, where a GTAC guy wanted me to activate the dumb file creation.

I did, created the dumpfile, send it, and deactivated the dumb file creation. (i thought)

 

the unchecked checkbox "Enable dumb file creation" implied that everything is deactivated,

because it looks like a Tree with hierachy. But the button "Enable diagnostic tool" and "Enable dumb log file creation" is still active.

It might be that "Enable diagnostic Tool" attaches a debugger to the tune.exe. As a result, Visual Studio can't attach to the process, because another one is already attached.

dumpfileCreation_deactivated.JPG

 

To solve it:

Tecnomatix Doctor (Adminrights) -> Tools -> Dumb file creation -> disable "Enable diagnostic tool"

it should look like:

dumpfileCreation_solved.JPG

 

PS:

I know it's called "dump" instead of "dumb", but this is the stupidest self-produced bug I've ever seen