Showing results for 
Search instead for 
Did you mean: 

Device compilation failed


Hello everybody,


I am currently on Process Simulate Standalone – eMServer compatible 14.0.

When I edited the links to my gripper and whanted to close the kinematics editor I got the error "Device compilation failed. Do you wish to close the Kinematics Editor?"


What could be the cause of this error?image.png


Re: Device compilation failed

Siemens Phenom Siemens Phenom
Siemens Phenom

Your layout seems ok.


But it looks like you added a toolframe!? (At least usually the tool-frame-button shouldn't be greyed)

The tool-/baseframe-buttons within the Kinematics Editor are to be used for inverse kinematics only.

If you have any old toolframes (special icon) in your component, remove them from the tree.


To define your tool as gripper, you need to:

  1. define the kinematics
  2. use "Modelling>>Tool Definition" to set your TCPF and the gripping entities


Re: Device compilation failed


Thank you for your answer.


I did not find anything more to add in the Kinematics editor and when I tried to open the "Tool Definition" I got the following message.


I did not find a way to fix the tool except deleting it and then drag and drop the cojt file in to the graphic window. Now it works as expected.


I am used to working on the eM-server version of Prosess Simulate.

One thing that annoys me with the stand alone version is that I can't bring upp the Properties pannel on resources in my study and I can't use the Navigation Tree. Is that how it isa supposed to be or is my verion bugged? 

Re: Device compilation failed

Siemens Phenom Siemens Phenom
Siemens Phenom

If you would have expanded all your links, you would have probably found a frame like below. Underneath one of the links.


Unlike the standard-frame they have this green key on it.

Here you get into trouble if the component has only a tool-frame, but no base-frame.


Both the Properties-panel and the Navigation-Tree are views on the eMServer-data.

Of course in Standalone, both are not available.

But you can start PS-eMServer, select the project and then load your .psz-file.

1. now you can access the properties

2. you can update the eMServer-data with the .psz-data

Re: Device compilation failed




The project where the PSZ-file was created from is deleted. How do I add it to a new project?



Re: Device compilation failed

Siemens Phenom Siemens Phenom
Siemens Phenom
Copy your .cojt to the new sysroot.

On eMS use “create engineering library”

On standalone use “define component type”, browse to your component, select (almost) any type.
This will create/update the tunedata.xml inside the .cojt
After that you can “insert component” or just D&D from Explorer into an open study.