Cancel
Showing results for 
Search instead for 
Did you mean: 

External axis problem / RCS Kuka (-56) error

Siemens Creator Siemens Creator
Siemens Creator

Hi all,

 

I have made an continuous feature operation and used arc continuous positioning to set up values for external axis (positioner). External axis is defined in robot properties.

The problem is that simulation is running only when auto teach is ON, after i turn it OFF i get an error that the location can't be reached.

I can also jump or move to location in path editor.

 

I use Kuka robot with Kuka-Krc controller.

Do anyone know where I made a mistake?

 

Thanks.

5 REPLIES

Re: External axis problem without auto teach mode

Siemens Phenom Siemens Phenom
Siemens Phenom

Do you simulate with KUKA RCS or with Tecnomatix internal motion planner (MOP)?

Re: External axis problem / RCS Kuka (-56) error

Siemens Creator Siemens Creator
Siemens Creator

Hi,

I did it with MOP, because i had a hard time with setting up Kuka RCS, but i have tried to set this up today, unfortunately unsuccessful.

 

I installed the rcs modules compatible with my robot backup using Kuka Mapping Table and changed rss file.

1 (3).png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

1 (4).png

		</Controller>
		<Controller Name="Kuka-Krc">
			<InstalledVersions>
				<Version Name="krc8.3_r14" CustomizedPath="d:\TXRoot\OLP_config_files\Kuka-Krc">
					<ModuleName>D:\Program Files\Tecnomatix_12.0TR1\rrs_bin\rcs_krc1\krc8.3_r14\bin\rcskrc1_tune.exe</ModuleName>
					<ModulePathName>D:\Program Files\Tecnomatix_12.0TR1\rrs_bin\rcs_krc1\krc8.3_r14\bin</ModulePathName>
				</Version>
				<Version Name="krc8.3_r11" CustomizedPath="d:\TXRoot\OLP_config_files\Kuka-Krc">
					<ModuleName>D:\Program Files\Tecnomatix_12.0TR1\rrs_bin\rcs_krc1\krc8.3_r11\bin\rcskrc1_tune.exe</ModuleName>
					<ModulePathName>D:\Program Files\Tecnomatix_12.0TR1\rrs_bin\rcs_krc1\krc8.3_r11\bin</ModulePathName>
				</Version>
				<Version Name="krc8.2_r01" CustomizedPath="d:\TXRoot\OLP_config_files\Kuka-Krc">
					<ModuleName>D:\Program Files\Tecnomatix_12.0TR1\rrs_bin\rcs_krc1\krc8.2_r01\bin\rcskrc1_tune.exe</ModuleName>
					<ModulePathName>D:\Program Files\Tecnomatix_12.0TR1\rrs_bin\rcs_krc1\krc8.2_r01\bin</ModulePathName>
				</Version>
			</InstalledVersions>
		</Controller>

When I try to validate the robot i get an error (-56):

1 (1).png

1 (2).png

There is written that there is no such directory but it exists.

I have tried to perform this validation/initialization of rcs module with mada files downloaded from GTAC and OLP ftp and it also doesn't work.

 

All attempts were made on PS12TR01 and using plain project with robot only (without external axis).

 

What have i made wrong?

Re: External axis problem / RCS Kuka (-56) error

Siemens Phenom Siemens Phenom
Siemens Phenom

Please install the KUKA RCS in a path that does not contain white spaces.

Re: External axis problem / RCS Kuka (-56) error

Siemens Creator Siemens Creator
Siemens Creator
Great, it works now. Thank you.
Would you be so kind and explain me why i get error when i simulate with MOP (my first question)?

Re: External axis problem / RCS Kuka (-56) error

Siemens Phenom Siemens Phenom
Siemens Phenom

There are open PRs/ERs regarding MOP simulation and positioners...