Cancel
Showing results for 
Search instead for 
Did you mean: 

Fanuc RCS V7.60 Robot Config Problems

Experimenter
Experimenter

 Hello,

I'm using Process Simulate 13.0 with Fanuc RCS V7.60 Rev.B Build 7.60.14.70

In the path editor, I have a working path with all robot configs properly assigned, set with 'Auto-Teach'.

When playing the simulation from the path editor with Auto-Teach off, everything is correct except the robot moves to the last point with the wrong config and the config changes in the field (from FUT000 to FUT010). I even added an additional point to ensure the shortest angle move is with the proper config, but it still rotates axis 4 the longer direction to use the wrong config!

 

I do have an error when validating the RCS: "Incompatible Controller version (V7.63) and RCS version (V6)"

however my liscense manager says I'm using "RCS V7.60," and everything else seems to work. Please advise.

 

Additionally, the simulation will play 1 time through to the end after validating the RCS, but after 1 run through for another iteration, it will immediately end after selecting the 'play' button with no robot movement. *This problem has since disappeared for an unkown reason, but any insight would be appreciated!* (The only change point I'm aware of is that I copied the first point to the end of the program while attempting to resolve the config problem!)

 

Finally, I cannot find any way to change the axis-turns (numbers in config) from the robot config editor, like the +/- buttons in newer Fanuc RCS (8.23). These buttons are always 'greyed out' in V7.60, for me.

Any good solutions/workarounds? I've only found joint jogging the axes to the proper setting and then 'teaching' the config. This will show the proper config, but I still have the problem described above where the software changes it.

 

Please help!

Thanks,

Kyle

1 REPLY

Re: Fanuc RCS V7.60 Robot Config Problems

Experimenter
Experimenter

Solved! For reference;

The 'motionparameters.e' file was wrong.

 

The non-working version;

*  	CONFIG
*******************************************************
config_family            	cf_over_head_pos;
joint_config_family	j1      joint_cf_cos_pos;
joint_config_family	j3	joint_cf_elbow_up;
joint_config_family	j5	joint_cf_pos;
*
*******************************************************
*  	TURNS
*******************************************************
default_turns 		j1 0 -180,	j4 0 -180,	j6 0 -180;
*

The corrected version;

*  	CONFIG
*******************************************************
motion_space                             space_karel; 
use_config                               use; 
interpolation_type                       interpolate_by_2; 
single_joint_prof                        single_prof; 
config_family            	cf_over_head_pos;
joint_config_family	j3	joint_cf_elbow_up;
joint_config_family	j5	joint_cf_pos;
*
*******************************************************
*  	TURNS
*******************************************************
default_turns 		j1 0 -180,	j4 0 -180,	j6 0 -180;
*