Showing results for 
Search instead for 
Do you mean 
Reply

Fanuc RCS problem

Hello Everybody!

 

I am using Process Simulate Standalone 12.1, and i realise, if i used just a normal fanuc controller the cycle time was "not real" so i tried to install the rcs module (8.20).

After the installation the vrim.exe and the vrimserve.exe is running when i saw in the task manager.

After then i start the program and opened the controller configuration windows again i can choose the manipulation type by the rcs, but my problem is that the RCS status does not change(stil ------), and when i start an operation it gives me the message, wich can you see on the first picture.

A was made virtual robot, but when i open the browser with http://localhost:9080 there is no active robot.

I am a new user,and i don't know what is missing.

(After the error message the operation start and the cycle time is smaller than the normal fanuc controller, so it is using the rcs but not the correct way)

 

Has somebody something idea what do i have to do?

Thanks

Attila

7 REPLIES

Re: Fanuc RCS problem

What the status -58 does mean?

 

David

Re: Fanuc RCS problem

Let see the problem_RCS4.png file please.

Re: Fanuc RCS problem

Error code 58 indicates a license problem!

Re: Fanuc RCS problem

Hello kalmanattila,

 

Have added a pdf explaining the steps that has to be follwed while RCS configuration.

 

The error posted by you might happen if u have missed configuring any of these steps explained in page nos 2, 5, 6, or 7.

 

Please check and confirm accordingly.

Re: Fanuc RCS problem

Hello Sanjaya Kumar,

 

I red your pdf, it was very helpful, but not for all problems.

(I forget make the specific.cfg)

But please let se the new files, about the new problems.

I had reading the documents of the rcs but i don't understand how can i start the virtual robot(s).

Because only one virtual robot started after i tried to run the simulation with the configuration, what i red in your pdf.

(i saw in the browser,http://localhost:9080/activerobots?TermSubmit=Terminate only one robot but in my simulation is three robot and i was setting up the rcs for all robot.)

Today i can't see any active robot.

Re: Fanuc RCS problem

Hi kalmanattila,

 

Could you please provide me some snapshots of contents which you have added in

1. specific.cfg

2. standard.cfg

3. local host screen( with the content of active robots)

 

these data could help analysing the problem better.

 

Thank you.

Re: Fanuc RCS problem

Hi.

 

This may not help, but I have seen where both "Simulation" AND "Non-Simulation" must be checked in the Controller Settings dialog to allow correct initialization.