Cancel
Showing results for 
Search instead for 
Did you mean: 

Fanuc RCS problem

Creator
Creator

Installed a fanuc RCS today, we are running process Simulate 12.1.1. With RCS not running the gun will go directly to the spot, but when I have RCS running, the gun goes through the metal 20.0mm. I have been searching for a good minute now and i cannot figure out where this offset it. I have tried reversing the (Z) direction on the gun, but nothing seems to fix this issue. 

 

Also, trying to figure out where the setup is for the gun ratio so that it will open at the correct distance. Would that be in the Kinematics? Rightg now the gun has a max opening of 50mm(and its wide open), and that really should be about 225mm. But I cannot see where I would change the value(ratio) at? 

 

 

Any help would be great.

 

Thank youservo.png

6 REPLIES

Re: Fanuc RCS problem

Siemens Phenom Siemens Phenom
Siemens Phenom

There are many parameters in Robot Setup / Robot and Guns Setup that influence the servo weld motion done by Fanuc RCS, in particular thickness and push_depth that influence the closure value.

Re: Fanuc RCS problem

Creator
Creator

Where do you access that information at? When I go to the Robot and Guns setup the information available appears to be pretty limited. I played around with all of the parameters and have had no luck. Is there something outside of process simulate perhaps in the fanuc software that I need to go into and calibrate the gun?

Re: Fanuc RCS problem

Siemens Phenom Siemens Phenom
Siemens Phenom

You will have more information in a Fanuc Servo Gun user manual about all the system variables and how they influence the servo gun welding auto-route motion.

Re: Fanuc RCS problem

Creator
Creator

Where do I access the FANUC variables on this system? I am very familar with them. I just cant seem to find where they are located at. 

Re: Fanuc RCS problem

Experimenter
Experimenter

I appreciate the replies, I figured it out. Basically I was overthinking the system. I have played around with roboguide alot and I was thinking maybe this sytem interacted the same way. Apparently it does. All is good now. Thanks again. 

Re: Fanuc RCS problem

Experimenter
Experimenter

The reason your having this problem is that when you created your Virtual robot personality you forgot to click Insulated faceplate, in the Setup Wizard. (I cannot get a pic of it into this reply box) It would be the 28th step, on the screen where you type in the Virtual Robot Path. There are boxes to check, it's the 3rd box down. I had the same issue this past week.