Showing results for 
Search instead for 
Do you mean 
Reply

Grip_action_smart_compoonent

Hello again.

 

I used to have Grip action for virtual commisioning in event simulation i PS11.1. It used to work fine and it worked few times with this gripper, then, maby i changed somethig accidentialy, it stoped gripping part... just move forward.

 

gripper type as gripper, gripping entitis set, Gripped Object List set, grip_action inside the gripper with additional condition "RE (grip_when_clamp_a_closed)" with the TCP, matirial flow operations done, signals connected to logicblock, so disconnected from simba. I even tried to force this signal for grip..

 

Have anyone any idea why it stoped working? I can't implement this for rest grippers also now, or maby it's just a contingency..

5 REPLIES

Re: Grip_action_smart_compoonent

Hello Gargur

In general - it should of course still work. 

Have you switched versions? Which version are you now using?

Did you load the same data that was modeled in 11.1 or has it changed since? Is your gripper moving (assuming there's motion involved when gripping) when the signal is triggered but is simply not gripping the part, or does the grippe not move at all (meaning it does not really recieve the signal)? 

 

Can you try an example from scrach on your system (meaning to create a new part\gripper and try them out to see if there's a general problem in your system, or just a problem with the specific data).

 

 

 

 

Kind regards,
Gal Snir

Re: Grip_action_smart_compoonent

Hello,

 

I didn't switch versions, it was on the same cell, the sime time i had it open.

 

Gripper is a equipment prototype, and every clamp is different smart component with signal in/out, movement is working fine.

I also though that simply signal is not going through and create new one on exit with the same imput as sensor of one of the clamp, and it's working.

 

 

Gripper is set as whole equipment, and there is logic for gripping, gripping element is one of the clamp.

 

I tried this also later on next gripper and its not gripping..

 

I also though, that maby there is something with TCP definition, must it be the same in tool def and grip_action, or for grip its only that to what part will be attached?

 

There is also one more information. I changed offset in tooldefinition for 1000, and left signal when close (on RE) he should grip. Clamps are closing in process point and whole Simulate is slowing down, it looks like gripper is looking for part to grip. Also when i changed this offset to 40 and logic for gripping action for true gripper is slowing down when move closer to part..

Re: Grip_action_smart_compoonent

Hello

Do you have access to GTAC? I think you should open an IR and supply some data with it so it can be looked into by SPLM development. This might still be a definition problem (since it worked before, right?), but it's hard to say by remote.

There's no limitation regarding the TCP frame and the Grip frame. It should be possible to have the same frame for both or different frames as you prefer (in which case yes - the grip frame is simply the frame to which the part is attached).

Regarding the slowdowns - it does make sense to me since when the gripper is closer to the part collision detection becomes harder and process simulate might be slowed down by this, especially if you use such high offset values which impact collision detection considerably.

Thanks,
Gal
Kind regards,
Gal Snir

Re: Grip_action_smart_compoonent

[ Edited ]

Hi, 

I don't rellay know a solution,  but when you say the simulation is slowing down,  I believe there's some cyclic mistake in the logic. 

Is the grip action executed several times? 

Usually it happens only ones,  so it slows down only a single time interval for a few miliseconds... 

 

Re: Grip_action_smart_compoonent

[ Edited ]

Hi,

 

It was slowing down, because that was a test with 1000 offset.

 

All the logic inside is RE (clamp_closed) so the grip action is executed only once.

 

I tried to attach part with operation seted on same signal, and it's working.

 

 

Edit: There is new information about my trouble. In the same project i created this logic in another gripper and it's working but in the previous cell 3 grippers still are not.

 

There is one more thing - when i changed matirial flow, that there was only pick operation, part did't appear - I added part to it as always via properties of operation and when I right click on it and generate appeariences by hand it's appearing