Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: .NET API (C#) creating a pick listener

Valued Contributor
Valued Contributor

This is so weird, just launched PS and my button isnt doing anything...the button is in PS, but nothing happens when I click it.

 

Restarted my laptop first, didnt do the trick

Deleted the old button, registered the button again, also no succes.

 

I had an old .dll in backup, this one is working fine, application is being launched. 

 

The class that implements TxButtonCommand launching the button has not changed...

 

What could be the problem here? 

 

Best Regards,

 

Pim

Re: .NET API (C#) creating a pick listener

Siemens Phenom Siemens Phenom
Siemens Phenom
No Idea.

But you may contact txapi_support.plm@siemens.com
Maybe they can help, but keep in mind this is not the official GTAC support.


-----------------
Siemens Industry Software GmbH & Co. KG; Anschrift: Franz-Geuer-Str. 10, 50823 Köln;
Kommanditgesellschaft: Sitz der Gesellschaft: Köln; Registergericht: Amtsgericht Köln, HRA 28227;
Geschäftsführung und persönlich haftender Gesellschafter: Siemens Industry Software Management GmbH;
Geschäftsführer: Urban August, Daniel Trebes; Sitz der Gesellschaft: Köln; Registergericht: Amtsgericht Köln, HRB 70858

Re: .NET API (C#) creating a pick listener

Legend
Legend

Maybe your botton command is executed, but because of an error in the code the execution stops before your main code is executed.

 

To find the issue, you could run PS in debugging mode, that allows you to see an exception if occurs.

Re: .NET API (C#) creating a pick listener

Valued Contributor
Valued Contributor

Thank you for the debug solution! I'm using another API in the same application that is using the tecnomatix API these had some trouble getting along.