cancel
Showing results for 
Search instead for 
Did you mean: 

OPC UA connection in Process Simulate 13.0

Pioneer
Pioneer

Hello,

 

I have an OPC UA connection configured as an external connection in Process Simulate. I am able to validate the connection successfully in PS, but none of the PS signals (M/Q) change according to my PLC code or the other way around: PLC signals (M/I) doesn’t change when my PS is sending signals. It looks like a problem in PS because all the signals can be modified between TIA Portal and OPC Scout.

 

Everything works great when using "normal" OPC DA -connection.

 

So if the OPC UA connection is valid, is the problem in my signal clarifications (I have tried like all the possible combinations but what is the correct way to assign signals in PS when using OPC UA connection)?

 

Any help will be appreciated!

 

 

Best regards,

SaMe

11 REPLIES

Re: OPC UA connection in Process Simulate 13.0

Pioneer
Pioneer

Is here anyone who has used OPC UA connection with Process Simulate, is that even possible yet?

Re: OPC UA connection in Process Simulate 13.0

Siemens Legend Siemens Legend
Siemens Legend

Hello SaMe

 

OPC UA connection in PS is possible - but still limited - currently PS allows communication of String nodes only. What node types are you sending\recieveing? 

 

Signal communication is named based. PS currently uses Browse Name to send\recieve signals 

 

 

OPC UA3.jpgOPC UA1.jpgOPC UA2.jpg 

Kind regards,
Gal Snir

Re: OPC UA connection in Process Simulate 13.0

Experimenter
Experimenter

Can I ask how you got the connection to validate in the first place? I have tried with three different opc ua servers and what happens with every one of them is that I can browse the end points but as soon as I click on them I get "Connection is failed", without any more details. Is there some undocumented setting you need to do to the server?

 

If I manually enter an adress and namespace index PS does not even seem to try - I turned off the server and jsut opened a listening socket on the port,, nothing tries to connect to it.

 

OPC DA works fine. But I would really like to leave it behind now that UA is maturing.

Re: OPC UA connection in Process Simulate 13.0

Siemens Legend Siemens Legend
Siemens Legend

Hello mdp

 

Try starting PS as Administrator. I think it should resolve your issue.

 

 

In any case - I was in err before regarding how to map signals.

PS uses the "Identifier" field, so looking at my exmplae above your signals will need to be named:

Demo.Static.Scalar.Boolean and the connection will need to have a NameSpaceIndex of 2 of course. This is what the images show but I wrote something different so I am correcting it.

 

What OPC UA servers are you using?

I am wondering how signal names in different system get trasnlated to Identifiers with different OPC UA servers as this currently has an effect on signal mapping.

 

 

 

Kind regards,
Gal Snir

Re: OPC UA connection in Process Simulate 13.0

Experimenter
Experimenter

Thanks for the quick reply! Starting as administrator (why this would help I have no idea)  I was successfully able to connect to, and validate a connection to the Unified Automation reference server.

 

I also tried the Milo example server from the eclipse project (https://github.com/eclipse/milo). This did not work out of the box. Either PS or Milo is not handling everything correctly, I don't know what the specification says but Milo crashed on null endpoints for me out of the box (so maybe something missing from the PS requests, or Milo should fill in if missing). Some hacks to the code to provide this I was later successful in connecting. Identifier strings seem to work fine. Adding some pictures for reference.

 

regards,

Martin

Re: OPC UA connection in Process Simulate 13.0

Valued Contributor
Valued Contributor

opcua.PNG

Hello

 

can I know where this photo information comes?

 

I am facing same issue for read/write data from PS 13.1 to OPCUA

 

Thanks

Re: OPC UA connection in Process Simulate 13.0

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello,

 

The application you are looking for is "UAExpert".

 

 

Best regards

Patrick

Re: OPC UA connection in Process Simulate 13.0

Valued Contributor
Valued Contributor

Thanks , can you please share the direction for PS connect with OPC UA in different IP address?

 

such as my PS laptop IP is 19.244.105.1, another laptop with kepware OPC UA IP is 19.244.104.1?

 

thanks

Re: OPC UA connection in Process Simulate 13.0

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi,

 

To do this, both PCs should be in the same network.

PS only gets the connection to OPC server. So you need to be sure there is a communication between your PS client and your OPC server.

This is an administrativ task. Nothing related to PS.

 

Best regards

Patrick