Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Problem importing cojt to RobotExpert

Hi,

I'm trying to import .cojt-files to RobotExpert. The file is a UR5 robot downloaded from Tecnomatix Products - Product Updates - Robot Models - Universal - UR5.cojt.zip

 

See the attached photo.2016-04-19_14-10-06.png

 

I'm completely new to RobotExpert, so I have no clue how to fix this...Thanks!

4 REPLIES

Re: Problem importing cojt to RobotExpert

Hello lagi

 

Is this a new cell you created or an existing one that you opened? 

This isn't a problem with the robot model (I tried downloading and inserting it), so try re-defining the component type of the robot:

1. Look into the COJT you downloaded and delete the "TuneData.xml" file in it (this will get rid of the current type defintion).

2. In RBX - open a cell or create a new one and run the "Define Component Type" command. Browse to your COJT and select it. Select "Robot" as the type when you see the type list. 

3. Use Insert Component again.

 

I hope this solves you problem.

Kind regards,
Gal Snir

Re: Problem importing cojt to RobotExpert

[ Edited ]

I can't find the "Define Component Type Command" in RBX12.1.3, do you know where it is? I guess this is not the same as importing a component using the import function? Because then I can define it as a robot...

Solution
Solution
Accepted by topic author lagi
‎04-21-2016 10:21 AM

Re: Problem importing cojt to RobotExpert

Use the File-Import/Export-Convert CAD Files command. Select the cojt folder if exists, if not - the jt file itself, then define other settings, including a "robot" type. You can check the Insert Component checkbox to automatically insert it into the cell upon apply.

Gil.

 

Re: Problem importing cojt to RobotExpert

Yeah, I mixed up Robot Expert with Process Simulate.

In Robot Expert there's no "Define Component Type" command and you need to do as GilChen suggested. 

Kind regards,
Gal Snir