Cancel
Showing results for 
Search instead for 
Did you mean: 

Process Sim v14, Client access to emsagent

Experimenter
Experimenter

Hi All,

 

We have recently updated to Process Sim 14 from 12.1.3 and now the Client machines no longer have access to the emsagent. Similar error was corrected by adding a rule to the firewall for 12.1.3, but i was wondering if something has changed with the naming, the port.. etc

 

The error is shown below.

 

R:\PROPLANNER\SHARED\lib\NoticeMechanism\NmSubscribeObs.cpp(392) PF:ERROR> finishCollecting: throw an exception @ Tue Sep 19 13:36:13.282, 2017
[0:7756] R:\PROPLANNER\Client\Api\EmpDataEvents\CEmpDataEventsHandler.cpp(111) PP:ERROR> Got PpException: Notification mechanism error occurred: Failed to connect to eMSAgent due to inability to initialize client subscriber. The RPC server is unavailable.

 @ Tue Sep 19 13:36:13.283, 2017

 

Any ideas?

 

Cheers,

 

Duncan.

5 REPLIES

Re: Process Sim v14, Client access to emsagent

Experimenter
Experimenter

Hi, after long installation process I can connect to eMServer from client with server firewall turned off. Can anyone tell me which ports I have to allow to connect from client to eMServer?

Re: Process Sim v14, Client access to emsagent

Experimenter
Experimenter

Hi,

 

We have port 1521 inbound and outbound as well as the emsagent.exe & tune.exe.

 

Also make sure you have set the correct permissions in the DCOM

 

Cheers,

 

Duncan.

Re: Process Sim v14, Client access to emsagent

Siemens Genius Siemens Genius
Siemens Genius

Hi,

 

This should help...

 

eM-Server

Ports 53, 135 and 445 should be opened on both server and client, and any firewall in between.

53 is for DNS lookup

135 is for RPC (DCOM)

445 is for SMB - to access the system root

Re: Process Sim v14, Client access to emsagent

Experimenter
Experimenter

Thank for the fast replies. After playing with the firewall log file, I found out that the port is 50556, it is the listening port of some dllhost.exe. Now it is working fine!

Re: Process Sim v14, Client access to emsagent

Experimenter
Experimenter

I figured out. The Port is decided by DCOM and dynamic. I had to change the registry according to https://support.microsoft.com/en-ca/help/154596/how-to-configure-rpc-dynamic-port-allocation-to-work...

 

After that I allow this range in the Firewall Inbounds.