cancel
Showing results for 
Search instead for 
Did you mean: 

Process Simulate being "locked"?

Creator
Creator

Hello all,

 

I am trying to edit and build onto an existing Process Simulate study. The import works without error and I can add new logic/operations etc. just fine. However, I can NOT set the modeling scope, edit/delete any of the resources in the study or use features such as the smart component wizard. My generated operations run on their own but not in Line Simulation, there is no reaction at all. All of these functions worked just fine in a trial empty Sandbox run and I have tried both LS and SS mode as well as previous PS versions. Still, all the resources are not alterable.

 

What properties of the study could be causing this behavior and what are ideas to fix it?

 

Thanks!

4 REPLIES

Re: Process Simulate being "locked"?

Siemens Legend Siemens Legend
Siemens Legend

Hi

 

This is very little information to go on for such as issue...

If you cannot set a components in modeling first check if it's a .COJT or a Robcad .CO (which cannot be modeled in PS). 

For the LS\SS issue - I think you should report it to GTAC.

Kind regards,
Gal Snir

Re: Process Simulate being "locked"?

Creator
Creator

@Gal_Snir

Thank you very much for response. It turns out that the folder files are indeed .co, so that partly explains the problem.

 

It would be the perfect solution for me to delete those .co components that I would like to work on and import them as .cojt instead, but they cannot be deleted.

The same is true for the operations which I believe are causing the problem when trying to run in LS. I am guessing you suggest that I file an Incident Report with GTAC and explain to them?

 

Regards,

 

EDIT: Reimported my files as .cojt and when I set modeling scope (which indeed became available now that they aren't .co), I received the following error that I could not find anywhere on here:

The selected object is not valid for modeling.

 

Does anyone know what causes this?

 

 

Re: Process Simulate being "locked"?

If the object is a TxComponent and it doest have a type set then you will get this error.

 

If you are pulling in a cojt model that has not been created in PS then it does not have a component type set in its TuneData.xml file.  If that file doesn's exist in the cojt folder or it is missing a defineition like the below... Then it will give that error.  If you are trying to open automatically in C# code then the model has to have the type defined before trying to open for modeling. Use the "Define Component Type" button.

 

<ProcessModelType><Type>Bracket</Type><Family>ToolPrototype</Family></ProcessModelType><ProcessModelData><Weight>0.000</Weight></ProcessModelData></ProcessModelPrototype><ProcessModelPrototype ProjectId="PP-CSCH1-24-9-2016-6-18-13-0-35534940"><ProcessModelID><ExternalID>PP-PS_SCHEMA_B-22-12-2016-10-38-37-8013027-8548162</ExternalID></ProcessModelID><ProcessModelType><Type>PmToolPrototype</Type><Family>ToolPrototype</Family></ProcessModelType>

Re: Process Simulate being "locked"?

Here is a method to create a Tool Prototype type component that a logic behavior can be set to in code.  I have a logic block importer application already written that does this.  Below is a sample fpr inserting user model Component node for Fanuc DCS to model in.  when it is created it is automaticall in Modeling Scope.

 

You can then add in Logic Behavior to a component using those class' methods.

 

  TxNewPartResourceParametersEx txNewPartResourceParametersEx = new TxNewPartResourceParametersEx();
            txNewPartResourceParametersEx.Type = "PmToolPrototype";


            TxApplication.CommandsManager.ExecuteCommand("ComponentOperations.NewResource", txNewPartResourceParametersEx);
            TxComponent newblock = txNewPartResourceParametersEx.CreatedObject as TxComponent;
            newblock.Name = "UM" + lastNumofUM(RobotSelected);
            newblock.AbsoluteLocation = RobotSelected.Robot.Toolframe.AbsoluteLocation;