Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

RCS-Problems with ABB an external axes

Hi everyone,

 

I`m using PS 10.1 standalone with ABB RCS 5 in different versions.

 

In my current cell is a IRB6600 on an external axis whith spot welding application. I´ve transfered the all components from an old robcad project. I´ve configured the robot, set the rcs configuration, configured the rail as external axis and reuploaded the real program.

 

Everything seems correct, all vias have external axis values and i can jump the robot to any location. But when I try to start the simulation via path editor or sequence editor, I get the following error:

 

-----------------------------------------

Errors:
ir_110040r01[RRS]> Fehler: ModifyRcsData PhysicalAxisScale, 24;1000 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 1;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 2;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 3;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 4;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 5;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 6;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler an m2s40p20: RRS Meldung: ERROR:
                                       20170: The system was stopped
                                       An error was detected, which stopped the system.
                                      
                                       1) Check other event log messages occurring at the same time to determine the actual cause.
                                       2) Fix the cause of the fault.
ir_110040r01[RRS]> Hinweis an m2s40p20: RRS Meldung: ERROR:
                                        50065: Kinematics error
                                        The destination of the movement is outside the reach of the robot or too close to a singularity. Robot ROB_1.
                                       
                                       
                                        Change the destination position.

-------------------------------

 

 

I can jump all positions without problems but I can`t drive them, they are all in range. I´ve tried different rcs-versions but I´m not able to solve this problem. Does anyone know this problem and how to solve it?

 

 

4 REPLIES

Re: RCS-Problems with ABB an external axes

Can you check that on PS, the RCS server is using the appropriate local MOC.CFG (you can see it in the rcs server instance console that pops up)? If default external config file is used, the RCS robot instance will have no externals

 

Re: RCS-Problems with ABB an external axes

[ Edited ]

Okay, how I interpret the text, he uses the local moc.cfg. I also gave him another moc.cfg from an identical robot without an external axis and he recocnized the missing configuration. It also works with the standard controller.

Re: RCS-Problems with ABB an external axes

[ Edited ]

Okay, new day, new RCS-Version, new error message:

 

Errors:
ir_110040r01[RRS]> Fehler: ModifyRcsData PhysicalAxisScale, 24;1000 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 1;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 2;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 3;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 4;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 5;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler: ModifyRcsData LogicalAxisScale, 6;1 gescheitert: The specified parameter is not found. (-5)
ir_110040r01[RRS]> Fehler an m2s40p20: RRS Meldung: ERROR:
                                       20171: The system was halted
                                       An error was detected, which halted the system.
                                       
                                       1) Check other event log messages occurring at the same time to determine the actual cause. 
                                       2) Fix the cause of the fault. 
                                       3) Restart the program.
ir_110040r01[RRS]> Hinweis an m2s40p20: RRS Meldung: .\target.c 3918 No, or more than one tcp robot active
ir_110040r01[RRS]> Hinweis an m2s40p20: RRS Meldung: .\tgtunt.c 478 No tcp_robot active
ir_110040r01[RRS]> Fehler an m2s40p20: RRS Meldung: ERROR:
                                       20170: The system was stopped
                                       An error was detected, which stopped the system.
                                       
                                       1) Check other event log messages occurring at the same time to determine the actual cause. 
                                       2) Fix the cause of the fault.
ir_110040r01[RRS]> Fehler an m2s40p20: RRS Meldung: ERROR:
                                       20171: The system was halted
                                       An error was detected, which halted the system.
                                       
                                       1) Check other event log messages occurring at the same time to determine the actual cause. 
                                       2) Fix the cause of the fault. 
                                       3) Restart the program.
ir_110040r01[RRS]> Hinweis an m2s40p20: RRS Meldung: .\target.c 5333 No, or more than one tcp robot active
ir_110040r01[RRS]> Hinweis an m2s40p20: RRS Meldung: .\tgtunt.c 478 No tcp_robot active

 

Still don´t know what to do - ideas anyone? :/

 

 

Edit: When I try to Create/Update the Systemframes, i get the error "GettCellFrame BASE failed. The specified frame is not found. (-57)".

Solution
Solution
Accepted by topic author thebang2
‎08-26-2015 04:32 AM

Re: RCS-Problems with ABB an external axes

For your information:

 

after nearly thirty emails, five phone calls and ten days with the gtac we got the solution. The problem was caused by old RCS-Modules. The PRoblem was dificult to reproduce, because everything works exept for the 7th axis. Also my dummy pkz won´t work at my machine but runs great on the machine of gtac.