Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Robot Jog behaviour changes when mounting a tool in PS

Hi all,

 

I'm using a 3-axis linear robot with a telescopic trolley (x-axis) which moves twice the distance relative to the beam it's mounted on. Everything is working fine in "Robot Jog" without a mounted tool, but when I mount a tool the behaviour changes.

 

When starting from the machines zero-position I can't move the x-axis in a positive direction. It's stuck! I can still move it in a negative direction though. However, changing "Frame of reference" from "TCPF" to either "Working Frame" or "BASEFRAME" solves the problem. Only problem is that as soon as I close the dialog the reference frame switches back to "TCPF".

 

I should also mention that "Joint Jog" works regardless of the tool.

 

Is there a workaround for this or should I attach the tool to the robot instead of mounting it?

2 REPLIES

Re: Robot Jog behaviour changes when mounting a tool in PS

Hi,

this sounds like your TCPF of the tool does not match your kinematics.

As you have very few DOF, maybe your device just cannot follow your intended carthesian movement. This always feels like it's stuck.

If you have less than 6 DOF, you have to have an axis in your kinematics than is EXACTLY parallel to the robot-jog-axis you want to manipulate.

 

Solution
Solution
Accepted by topic author AndyV
‎08-26-2015 04:32 AM

Re: Robot Jog behaviour changes when mounting a tool in PS

After making sure the tool setup matched your description I tried to jog the robot, but unfortunately the problem remained. However, since I also had some problems setting the tool to modeling scope I started suspecting faulty geometry was causing problems with the kinematics. Therefore I drew a new simpler tool and mounted it the same way. Voila! Now it's working.

 

I have no idea if this is a plausible explanation, but aside from creating a simpler tool in my CAD software I didn't change a thing.