Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Saving human resource

Hi everyone,

 

I'm having some problems saving study on Process Simulate Standalone and i can't understand if it is a mistake of mine or a software problem.

I create my study with human and robot resources, I create operations with bot human and robot and it works fine.The I do the standard procedure to save the study (File-->Save OR File-->save as--> .psz extension).

When I open again that file I get the error that resorce and operation are not compatible. If I try to reproduce the simulation the robot works fine but the operator doesn't move anymore. I can't even "use" the human resource anymore, it is like I have no human resource because if I select the human I have no possibility to make him move or do any other operations.

 

Any idea? Do I have to do any particular procedure to save it correctly?

 

I hope I've been clear and you can understand, probably the images will explain better then my words.

Thank You

8 REPLIES

Re: Saving human resource

Hi Umbe,

error 1 is just a symptom of error 2.

 

I believe something is fishy while generating the human model.

Did you bring it from the library, or did you create it using "create human model"?

 

Is your

  • systemroot
  • Human>Human Options...>Human Model tab>Humand Model Library path

correctly defined?

 

Do you use "HUMAN_MODELS"-folder from the installed version? (\eMPower\Human\HUMAN_MODELS ... should not matter, but you never know...)

 

 

Re: Saving human resource

Hi Guido,

Thank you for the answer, but I still haven't solve it.

 

The human model library path was correctly set and I'm using the HUMAN_MODELS folder from the installed version.

I've been trying to save and open again the file in many different conditions but the result it always the same.
I tried also to create a human not from the library but with parameters (for example a girl), I "asked" her to do some operations (everything worked fine) and then I saved.

When I opened the study I got the same results (no human resource associated to the operations) but also the girl was replaced by jack (the human from the library).

 

I've started working on this project with a collegue of mine, and we both have the same problem on two different PC. So I guess uninstall and install again PS won't help.

Any other suggestion? I defenitely can't start working on a whole assembly line project before being able to save it!

 

Thank You,

Umberto

Re: Saving human resource

The error message looks like it's coming up when you try to simulate.

Is there a message that comes up when loading the study?

If yes and there is a path mentioned: can you copy and paste this path to the file-explorer?

Means: are you sure this path leads to Jack.cojt?

Re: Saving human resource

Actually the error comes up when I open the study (error1) and no path is mentioned.

 

When I simulate i get the second error "task has no human resource" (error2).

 

 

Re: Saving human resource

I would suggest to

  • make a backup of your .psz
  • remove your Jack from study
  • store, reload the study. There should be no message anymore
  • create a new Jack
  • select the process and click "assign human model"
  • store and reload

Still the same error?

Re: Saving human resource

I followed your instructions and the new Jack works, then I store and reload again and still the same error.


I tryed also in this way:

 

-create a new study with jack and operation (simply walk)

-store

-reload (the error appears)

-process-->assign to --> Jack

 

and the it displays the error " this is not a human model" (pic new_error)

Solution
Solution
Accepted by topic author Umbe
‎08-26-2015 04:32 AM

Re: Saving human resource

Hi everyone,

 

I've "solved" the problem. It is necesssary to run Process Simulate as administrator in order to have the software working properly. Probably it is not the best final solution but at least it works.

 

Best,

Umberto

Re: Saving human resource

Usually admin rights are not necessary to run PS.

Actually I rather believe your user was lacking write-access to some storage path...